summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-10-10 15:34:14 +0300
committerTor Lillqvist <tml@collabora.com>2013-10-11 13:15:03 +0300
commit09d246c82fa87a51e8c8100a3c37fcd32ea56e35 (patch)
tree523ab3844b574fe1ad96227dcc2721ea1dcf14fd /configure.ac
parent7f213aaae8f1ccb23f43852d7c22baf766685763 (diff)
Use libc++ on iOS
Change-Id: I722b28f0d432c051fbe3a55823bc64b8a86e9a17
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8670deccc89a..735d20e8fcdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2945,8 +2945,9 @@ if test $_os = iOS; then
# Just add -fvisibility=hidden to CC and CXX directly so that the 3rd-party libs also
# get compiled with it, to avoid ld warnings when linking all that together into one
# executable.
+ # Also, use libc++.
CC="`xcrun -find clang` -arch $arch -fvisibility=hidden -isysroot $sysroot $lto $versionmin"
- CXX="`xcrun -find clang++` -arch $arch -fvisibility=hidden -isysroot $sysroot $lto $versionmin"
+ CXX="`xcrun -find clang++` -arch $arch -fvisibility=hidden -stdlib=libc++ -isysroot $sysroot $lto $versionmin"
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`
NM=`xcrun -find nm`