summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2012-07-02 17:50:55 +0200
committerLuboš Luňák <l.lunak@suse.cz>2012-12-10 14:46:46 +0100
commitf24bae90c006c3522e3034b48d62c7e6cc7e45a8 (patch)
tree78be2f4da537d13ef074652e60871a83e0df44cd /configure.ac
parentf2d96655e0d78acefe6fe4707f09abec79243856 (diff)
enable PCH in configure only for msvc/clang
Change-Id: I83a5a2cc6a673165a230ac0c916fdd533a4ccaae
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 96f517e9c48c..195b832b5c3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4476,20 +4476,19 @@ AC_SUBST(HYPH_SYSTEM_DIR)
AC_SUBST(THES_SYSTEM_DIR)
dnl ===================================================================
-dnl ENABLE_PCH i now a no-op
-dnl ===================================================================
AC_MSG_CHECKING([whether to enable pch feature])
if test -n "$enable_pch" && test "$enable_pch" != "no"; then
if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
ENABLE_PCH="TRUE"
AC_MSG_RESULT([yes])
-dnl There is no PCH support in GCC versions prior to this
- elif test "$GCC" = "yes"; then
+ # GCC PCH support is reportedly a hack that's not very reliable,
+ # so support only Clang.
+ elif test "$GCC" = "yes" -a "$COM_GCC_IS_CLANG" = "TRUE"; then
ENABLE_PCH="TRUE"
AC_MSG_RESULT([yes])
else
ENABLE_PCH=""
- AC_MSG_WARN([Precompiled header not yet supported for your platform/compiler])
+ AC_MSG_ERROR([Precompiled header not yet supported for your platform/compiler])
fi
else
ENABLE_PCH=""