summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2016-11-02 14:13:54 +0100
committerMichael Stahl <mstahl@redhat.com>2016-11-02 20:04:23 +0000
commiteea709f67d91e271e3df37e6c6724b7b5870b1ee (patch)
tree170d8daf2c45e04f461556ede40699d3d6a4fc2c /configure.ac
parent092261ffd497f752c342f1fbdca6e7267e312a21 (diff)
poppler: build against libjpeg
Albert Astals Cid points out that --disable-libjpeg causes poppler to use internal JPEG code instead, which is not actively maintained. Add LIBJPEG_CFLAGS / LIBJPEG_LIBS to config_host.mk and patch poppler to respect LIBJPEG_LIBS. Change-Id: Id19a62a9bd9dc41fee5e8e43e2798e515aacc299 Reviewed-on: https://gerrit.libreoffice.org/30496 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 66a11a98a00a..9c24cbb7ce20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7716,10 +7716,10 @@ fi
if test "$with_system_jpeg" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_JPEG=TRUE
- AC_CHECK_HEADER(jpeglib.h, [],
+ AC_CHECK_HEADER(jpeglib.h, [ LIBJPEG_CFLAGS= ],
[AC_MSG_ERROR(jpeg.h not found. install libjpeg)], [])
- AC_CHECK_LIB(jpeg, jpeg_resync_to_restart, [ JPEG3RDLIB=-ljpeg ],
- [AC_MSG_CHECKING(jpeg library not found or fuctional)], [])
+ AC_CHECK_LIB(jpeg, jpeg_resync_to_restart, [ LIBJPEG_LIBS="-ljpeg" ],
+ [AC_MSG_ERROR(jpeg library not found or fuctional)], [])
libo_MINGW_CHECK_DLL([libjpeg])
else
SYSTEM_JPEG=
@@ -7768,12 +7768,18 @@ Alternatively, you can install the 'new' nasm where ever you want and make sure
_EOS
AC_MSG_ERROR([no nasm (Netwide Assembler) found])
fi
+ LIBJPEG_CFLAGS="-I${WORKDIR}/UnpackedTarball/jpeg-turbo"
+ LIBJPEG_LIBS="${WORKDIR}/UnpackedTarball/jpeg-turbo/.libs/libjpeg.lib"
else
AC_MSG_RESULT([internal, jpeg])
BUILD_TYPE="$BUILD_TYPE JPEG"
+ LIBJPEG_CFLAGS="-I${WORKDIR}/UnpackedTarball/jpeg"
+ LIBJPEG_LIBS="-L${WORKDIR}/LinkTarget/StaticLibrary -ljpeg"
fi
fi
AC_SUBST(NASM)
+AC_SUBST(LIBJPEG_CFLAGS)
+AC_SUBST(LIBJPEG_LIBS)
AC_SUBST(SYSTEM_JPEG)
dnl ===================================================================