summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2013-04-30 20:17:49 +0200
committerDavid Tardon <dtardon@redhat.com>2013-05-10 13:18:50 +0000
commitebef182253e7d49c5439ab5053a7243ad24207a7 (patch)
tree0f935b9afec26f4f6a56a3d7455dd9dbc636014d /configure.ac
parent0a20a9c011e294a6d28d7e42184cd13ada1274ad (diff)
don't override TMPDIR with /tmp on cygwin, cleanup TMPDIR/TMP handling
on cygwin, configure forced TMPDIR to /tmp, regardless whether it is set or not. And while it respects an existing value of TMP, TMP is only used in a few places. Changes the ones that explicitly check for TMP to prefer TMPDIR, and don't duplicate configure's check in other scripts. Change-Id: Ia8ac3f8d92e5f971c5237b85f66f7c0a58932930 Reviewed-on: https://gerrit.libreoffice.org/3701 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 6 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 6588eaf4de41..df8576527c11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11839,22 +11839,15 @@ PathFormat "$PERL"
PERL="$formatted_path"
AC_SUBST(PERL)
-if test "$build_os" = "cygwin"; then
- TEMP_DIRECTORY=`cygpath -m "/tmp"`
- if test -n "$TMP"; then
- TMP_DIRECTORY="$TMP"
- else
- TMP_DIRECTORY="$TEMP_DIRECTORY"
- fi
+if test -n "$TMPDIR"; then
+ TEMP_DIRECTORY="$TMPDIR"
else
- if test -n "$TMPDIR"; then
- TEMP_DIRECTORY="$TMPDIR"
- else
- TEMP_DIRECTORY="/tmp"
- fi
+ TEMP_DIRECTORY="/tmp"
+fi
+if test "$build_os" = "cygwin"; then
+ TEMP_DIRECTORY=`cygpath -m "$TEMP_DIRECTORY"`
fi
AC_SUBST(TEMP_DIRECTORY)
-AC_SUBST(TMP_DIRECTORY)
# setup the PATH for the environment
if test -n "$LO_PATH_FOR_BUILD"; then