summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKohei Yoshida <kohei.yoshida@collabora.com>2016-10-24 18:56:51 -0400
committerKohei Yoshida <kohei.yoshida@collabora.com>2016-10-25 18:07:27 -0400
commitdff4e51f5db23baab368ab7e656ad1b74f2663bd (patch)
treef5f108fc581f163aa815bd98ab2765ba4d02b524 /configure.ac
parent08086d76f86794963b3ab27168f9516edf7b9d2d (diff)
Add configure option --enable-formula-logger to conditionalize it.
Change-Id: I1badbcfa259b22d742e5241bd817ea44769a771e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af07d135032c..f06ef8e2806a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1515,6 +1515,13 @@ AC_ARG_ENABLE(dconf,
[Disable the dconf configuration backend (enabled by default where
available).]))
+AC_ARG_ENABLE(formula-logger,
+ AS_HELP_STRING(
+ [--enable-formula-logger],
+ [Enable formula logger for logging formula calculation flow in Calc.]
+ )
+)
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -12754,6 +12761,20 @@ else
fi
AC_SUBST(MPL_SUBSET)
+dnl ===================================================================
+
+AC_MSG_CHECKING([formula logger])
+ENABLE_FORMULA_LOGGER=
+
+if test "x$enable_formula_logger" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(ENABLE_FORMULA_LOGGER)
+ ENABLE_FORMULA_LOGGER=TRUE
+else
+ AC_MSG_RESULT([no])
+fi
+
+AC_SUBST(ENABLE_FORMULA_LOGGER)
dnl ===================================================================
dnl Setting up the environment.
@@ -12927,6 +12948,7 @@ AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])
AC_CONFIG_HEADERS([config_host/config_opengl.h])
AC_CONFIG_HEADERS([config_host/config_options.h])
+AC_CONFIG_HEADERS([config_host/config_options_calc.h])
AC_CONFIG_HEADERS([config_host/config_test.h])
AC_CONFIG_HEADERS([config_host/config_telepathy.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])