summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-12-21 17:27:39 +0100
committerMichael Stahl <mstahl@redhat.com>2012-12-21 17:29:44 +0100
commitdebd56b20ec505b57e70b6fd811539a36e3d5b93 (patch)
treef27bd74b6fd90bb230c3ef4d27b7cd4f65b43f33 /configure.ac
parent4ef5ed9d21de767ce1b4c70d73cf15994b38dcdb (diff)
gbuild: AsmObject: support user defined AFLAGS
There does not seem to be a point to using CFLAGS here, usual convention appears to be to use AFLAGS. Not target local, since right now there is no need for that. Change-Id: I5d2f45777c226c0afc632adc21e446f09740d75d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0a1394fe92ce..b4a6853b958c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3398,8 +3398,17 @@ else
fi
AC_SUBST(ENABLE_SYMBOLS)
-dnl Check for explicit C/CXX/OBJC/OBJCXX/LDFLAGS. We by default use the ones specified
-dnl by our build system, but explicit override is possible.
+# Check for explicit A/C/CXX/OBJC/OBJCXX/LDFLAGS.
+# By default use the ones specified by our build system,
+# but explicit override is possible.
+AC_MSG_CHECKING(for explicit AFLAGS)
+if test -n "$AFLAGS"; then
+ AC_MSG_RESULT([$AFLAGS])
+ x_AFLAGS=
+else
+ AC_MSG_RESULT(no)
+ x_AFLAGS=[\#]
+fi
AC_MSG_CHECKING(for explicit CFLAGS)
if test -n "$CFLAGS"; then
AC_MSG_RESULT([$CFLAGS])
@@ -3440,11 +3449,13 @@ else
AC_MSG_RESULT(no)
x_LDFLAGS=[\#]
fi
+AC_SUBST(AFLAGS)
AC_SUBST(CFLAGS)
AC_SUBST(CXXFLAGS)
AC_SUBST(OBJCFLAGS)
AC_SUBST(OBJCXXFLAGS)
AC_SUBST(LDFLAGS)
+AC_SUBST(x_AFLAGS)
AC_SUBST(x_CFLAGS)
AC_SUBST(x_CXXFLAGS)
AC_SUBST(x_OBJCFLAGS)