summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@gmail.com>2013-03-04 19:26:11 +0100
committerTomáš Chvátal <tchvatal@suse.cz>2013-03-06 14:25:52 +0000
commita8ba50d2c0f54aa40977c6da0898814573d6a5e0 (patch)
tree90847482629e1a38a387f2973dfc34b123274c10 /configure.ac
parent5575d7f3f3b2fcfdc2f9bbae7c8fb0805cb0f267 (diff)
XINC and XLIB are never used
Change-Id: I242153584dd8e50e8163c4534acf8d8a66423b02 Reviewed-on: https://gerrit.libreoffice.org/2545 Reviewed-by: Tomáš Chvátal <tchvatal@suse.cz> Tested-by: Tomáš Chvátal <tchvatal@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 2 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 7b0470572da9..9533c3da20d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8372,18 +8372,11 @@ if test "$WANT_X11" = "yes"; then
AC_PATH_XTRA
CPPFLAGS="$CPPFLAGS $X_CFLAGS"
- if test "x$x_includes" = "x"; then
+ if test -z "$x_includes"; then
x_includes="default_x_includes"
fi
- if test "x$x_libraries" = "x"; then
- x_libraries="default_x_libraries"
- fi
- dnl The variables $x_libraries and $x_includes are set.
if test -z "$x_libraries"; then
- AC_MSG_ERROR([No X libraries found]) # Exit
- fi
- if test -z "$x_includes"; then
- AC_MSG_ERROR([No X includes found]) # Exit
+ x_libraries="default_x_libraries"
fi
CFLAGS="$CFLAGS $X_CFLAGS"
LDFLAGS="$LDFLAGS $X_LDFLAGS $X_LIBS"
@@ -8392,33 +8385,6 @@ else
x_includes="no_x_includes"
x_libraries="no_x_libraries"
fi
-if test -z "$x_includes"; then
- x_includes="no_x_includes"
-fi
-if test -z "$x_libraries"; then
- x_libraries="no_x_libraries"
-fi
-if test "$x_includes" = "default_x_includes"; then
- XINC="/usr/include"
-else
- XINC="$x_includes"
-fi
-AC_SUBST(XINC)
-if test "$x_libraries" = "default_x_libraries"; then
- XLIB=`$PKG_CONFIG --variable=libdir x11`
- if test "x$XLIB" = x; then
- XLIB="/usr/lib"
- fi
-else
- XLIB="$x_libraries"
-fi
-if test "$XLIB" != "no_x_libraries" -a "$XLIB" != "/usr/lib" -a "$XLIB" != "/usr/lib64"; then
- SOLARLIB="$SOLARLIB -L$XLIB"
-fi
-if test "$XINC" != "no_x_includes" -a "$XINC" != "/usr/include"; then
- SOLARINC="$SOLARINC -I$XINC"
-fi
-AC_SUBST(XLIB)
if test "$WANT_X11" = "yes"; then
dnl ===================================================================