summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2013-10-15 17:10:01 +0200
committerStephan Bergmann <sbergman@redhat.com>2013-10-15 17:57:16 +0200
commit8fc7e560db11f424362c8effdeb61eb8d1526256 (patch)
treee0c6e491ec5ca24bce891cdf39068b835596f21e /configure.ac
parentcc2a405915e82c4b332dd25457f76704dc536d7f (diff)
Make building installation sets depend on --with-package-format=...
...instead of inconsitently having it depend on --enable-epm for some platforms and having it always enabled on Windows. Only Android and iOS are presumably still special and build any installation sets in their specific modules and outside instsetoo_native. One consequence is that for a non-Windows --enable-online-update --without-package-format build, instdir's version ini-file contains an UpdateURL that ends in just "?pkgfmt=" without an actual format identifier. However, checking whether the update feature would actually work is difficult for most such developer builds, anyway. Change-Id: If14fcf0b2e612499811e8a6e067a854bda612c42
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac63
1 files changed, 17 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index f3dfc1b1dcbd..0375a34abae8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1404,10 +1404,11 @@ AC_ARG_WITH(epm,
AC_ARG_WITH(package-format,
AS_HELP_STRING([--with-package-format],
- [Specify package format(s) for LibreOffice installsets. Default is the
- "normal" one of the OS/Distribution. Possible values: aix, bsd, deb,
- inst, tardist, osx, pkg, rpm, setld, native, portable, archive, dmg,
- installed, msi. Example: --with-package-format="deb dmg"]),
+ [Specify package format(s) for LibreOffice installation sets. The
+ implicit --without-package-format leads to no installation sets being
+ generated. Possible values: aix, archive, bsd, deb, dmg, inst,
+ installed, msi, native, osx, pkg, portable, rpm, setld, and tardist.
+ Example: --with-package-format='deb rpm']),
,)
AC_ARG_WITH(tls,
@@ -4400,7 +4401,7 @@ dnl ===================================================================
dnl Test which package format to use
dnl ===================================================================
AC_MSG_CHECKING([which package format to use])
-if test -n "$with_package_format"; then
+if test -n "$with_package_format" -a "$with_package_format" != no; then
for i in $with_package_format; do
case "$i" in
aix | bsd | deb | inst | tardist | osx | pkg | rpm | setld | native | portable | archive | dmg | installed | msi)
@@ -4428,49 +4429,11 @@ msi - Windows .msi
esac
done
PKGFORMAT="$with_package_format"
-elif test "$enable_epm" = "yes"; then
- # defaults
- case "$_os" in
- Darwin)
- PKGFORMAT=dmg
- ;;
- SunOS)
- PKGFORMAT=pkg
- ;;
- Linux)
- # if building on Debian, default should be deb...
- if test -e /etc/debian_version; then
- PKGFORMAT=deb
- else
- PKGFORMAT=rpm
- fi
- ;;
- AIX)
- PKGFORMAT=rpm
- ;;
- OpenBSD|DragonFly)
- PKGFORMAT=portable
- ;;
- *BSD)
- PKGFORMAT=bsd
- ;;
- WINNT)
- PKGFORMAT=msi
- ;;
- # we never should get here since we check the arciecture/os at the beginning,
- # but go sure...
- *)
- AC_MSG_ERROR([unknown system])
- esac
+ AC_MSG_RESULT([$PKGFORMAT])
else
- if test "$WITH_MINGW" = "yes"; then
- # when tested, we should default this to 'msi', instead of 'archive'
- PKGFORMAT=archive
- else
- PKGFORMAT=native
- fi
+ PKGFORMAT=
+ AC_MSG_RESULT([none])
fi
-AC_MSG_RESULT([$PKGFORMAT])
AC_SUBST(PKGFORMAT)
dnl ===================================================================
@@ -7463,6 +7426,14 @@ if test "$enable_epm" = "yes"; then
AC_SUBST(DPKG)
AC_SUBST(PKGMK)
else
+ for i in $PKGFORMAT; do
+ case "$i" in
+ aix | bsd | deb | inst | tardist | osx | pkg | rpm | setld | native | portable)
+ AC_MSG_ERROR(
+ [--with-package-format='$PKGFORMAT' requires --enable-epm])
+ ;;
+ esac
+ done
AC_MSG_RESULT([no])
EPM=NO
fi