summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-04-01 12:47:16 +0200
committerMichael Stahl <mstahl@redhat.com>2013-04-01 13:01:16 +0200
commit70fcfeedca045a5027999735269e07f9cd2f96f7 (patch)
tree795f3de1df4ffd9db03deff703569c3e7f061017 /configure.ac
parent823862ac02ec07fd20ee288d314e04015b0866df (diff)
Revert "use -isystem instead of -I for 3rd party headers"
This reverts commit 151abb8b2b9d3a22229b98cec12e29484d12109b. Unfortunately has the side effect that it will prevent GCC from generating makefile dependencies for headers from bundled external libraries, which breaks incremental builds horribly. (Retain the uses in configure for real system headers). Conflicts: RepositoryExternal.mk configure.ac Change-Id: I149db1d402fa18bdc470f90dee846cfb5158237e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 77f75407b1ad..3f06fbc425fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2883,6 +2883,7 @@ fi
AC_SUBST(HAVE_LD_BSYMBOLIC_FUNCTIONS)
# Use -isystem (gcc) if possible, to avoid warnigs in 3rd party headers.
+# NOTE: must _not_ be used for bundled external libraries!
ISYSTEM=
if test "$GCC" = "yes"; then
AC_MSG_CHECKING( for -isystem )
@@ -3973,7 +3974,7 @@ else
WORKDIR=${BUILDDIR}/workdir/${INPATH}
fi
OUTDIR="${SOLARVER}/${INPATH}"
-SOLARINC="-I. ${ISYSTEM}${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc -I$SRC_ROOT/solenv/inc $SOLARINC"
+SOLARINC="-I. -I${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc -I$SRC_ROOT/solenv/inc $SOLARINC"
AC_SUBST(COM)
AC_SUBST(CPU)
AC_SUBST(CPUNAME)