summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-29 11:00:37 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-29 11:07:12 +0200
commit62a7ad8debb8868eb3ba7635ce3d092562191acb (patch)
tree5ecc64af83845200fe2d4854cd3f81838c2bd6e5 /configure.ac
parent4e28077c645b16fc412fee039d5b4e368b697631 (diff)
Preserve timestamps of config_build/*.h, too, if unchanged
Change-Id: Ib2d6f3db0b4fa7d7558d82cdb464c8d707cd8f42
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b0b9140fc14b..52efca7a2cbd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4093,6 +4093,7 @@ if test "$cross_compiling" = "yes"; then
instsetoo_native/util/openoffice.lst.in) \
| (cd CONF-FOR-BUILD && tar xf -)
cp configure CONF-FOR-BUILD
+ test -d config_build && cp -p config_build/*.h CONF-FOR-BUILD/config_host
(
unset COM GUI GUIBASE OS CPU CPUNAME
unset CC CXX SYSBASE CFLAGS
@@ -4139,9 +4140,9 @@ if test "$cross_compiling" = "yes"; then
2>&1 | sed -e 's/^/ /'
test -f ./config_host.mk 2>/dev/null || exit
cp config_host.mk ../config_build.mk
- cp config.log ../config.Build.log
+ mv config.log ../config.Build.log
mkdir -p ../config_build
- cp config_host/*.h ../config_build
+ mv config_host/*.h ../config_build
. ./bin/get_config_variables OS PATH CC CXX INPATH SYSTEM_LIBXSLT OUTDIR WORKDIR
for V in OS CC CXX INPATH SYSTEM_LIBXSLT; do