summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiklos Vajna <vmiklos@collabora.co.uk>2017-02-13 17:05:19 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-03-14 12:05:13 +0100
commit5fdeb30cc78817ce85cb568053145752ff7ec215 (patch)
tree7d4f84c18f8a943e4bfa45f29ac9d87219be90e3 /configure.ac
parent08f0a54644c52a2c3da3b900ecf916639129e914 (diff)
vcl pdf import: use pdfium instead of draw_pdf_import
Replace creating a full Draw component with direct pdfium library calls. This also means that the result is now a bitmap, not a metafile for now. Also decouple HAVE_FEATURE_PDFIMPORT and HAVE_FEATURE_PDFIUM, the first is the "import PDF into Draw" feature, the second is the "insert PDF as image" feature. Reviewed-on: https://gerrit.libreoffice.org/34217 Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk> Tested-by: Jenkins <ci@libreoffice.org> (cherry picked from commit 6657d52417295265367cf3ffe5832b60e3c38011) Conflicts: config_host/config_features.h.in vcl/Library_vcl.mk vcl/source/gdi/impgraph.cxx Change-Id: I72c25642ec84cc831df362e02b1520c6e6d9adcf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0711a700b048..266cc4deb008 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10689,6 +10689,7 @@ ENABLE_PDFIUM=
if test -z "$enable_pdfium" -o "$enable_pdfium" = yes; then
AC_MSG_RESULT([yes])
ENABLE_PDFIUM=TRUE
+ AC_DEFINE(HAVE_FEATURE_PDFIUM)
BUILD_TYPE="$BUILD_TYPE PDFIUM"
else
AC_MSG_RESULT([no])