summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-01-01 08:54:11 +0100
committerDavid Tardon <dtardon@redhat.com>2013-01-01 09:02:07 +0100
commit55563832c492e5b03a88763cf15384655ba31181 (patch)
tree38a0cb335555e98e84d93b1e99148c37fe3834d9 /configure.ac
parent3f22967547f529e46651c9247d696dd7668943dc (diff)
check for python.exe too
Change-Id: I6f66348f8e40a7f977f33e145171489d7c57b8be
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 643f2320bead..eb0dd9ff994b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7532,7 +7532,12 @@ if test $enable_python = system; then
if test -f ${MINGW_SYSROOT}/include/python${python_version}/Python.h; then
PYTHON_CFLAGS="-I${MINGW_SYSROOT}/include/python$python_version"
PYTHON_LIBS="-L${MINGW_SYSROOT}lib -lpython$python_version $python_libs"
- MINGW_PYTHON_EXE=python.exe
+ AC_MSG_CHECKING([for python.exe])
+ AS_IF([test -f "$MINGW_SYSROOT/mingw/bin/python.exe"],
+ [AC_MSG_RESULT([$MINGW_SYSROOT/mingw/bin/python.exe])
+ MINGW_PYTHON_EXE=python.exe],
+ [AC_MSG_RESULT([not found])
+ AC_MSG_ERROR([could not find python.exe])])
libo_MINGW_CHECK_DLL([PYTHON], [libpython$python_version])
libo_MINGW_CHECK_DLL([READLINE], [libreadline6])
libo_MINGW_CHECK_DLL([TERMCAP], [libtermcap])