summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2016-08-30 09:27:05 +0100
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-02-13 08:22:29 +0000
commit53b186d85894c2c41afc025bda459db5cc6ef452 (patch)
tree71918796bcf2432539d5367d1a37b2f7d3394a21 /configure.ac
parentac0b2c90a9ae6a6442111b72113257fa16916d47 (diff)
Resolves: tdf#105426 upgrade to hunspell-1.6.0
and use alternative optimizations for buffer creation bottleneck Change-Id: I9f29e8d3e5e97fe403a3e0d7d03c6ac01c7689c4 (cherry picked from commit 163435fa23fbfc237a7718c9d440a98847e4f626) Reviewed-on: https://gerrit.libreoffice.org/34183 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b2e13e55d1d7..6d358b7c0fb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3860,6 +3860,11 @@ if test -n "$enable_dbgutil" -a "$enable_dbgutil" != "no"; then
else
with_system_libgltf=no
fi
+ if test "$with_system_hunspell" = "yes"; then
+ AC_MSG_ERROR([--with-system-hunspell conflicts with --enable-dbgutil])
+ else
+ with_system_hunspell=no
+ fi
else
ENABLE_DBGUTIL=""
MSVC_USE_DEBUG_RUNTIME=""
@@ -9585,7 +9590,7 @@ if test "$with_system_hunspell" = "yes"; then
HUNSPELL_LIBS=-lhunspell
fi
AC_LANG_POP([C++])
- libo_MINGW_CHECK_DLL([libhunspell-1.4])
+ libo_MINGW_CHECK_DLL([libhunspell-1.6])
HUNSPELL_CFLAGS=$(printf '%s' "$HUNSPELL_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${HUNSPELL_LIBS}"
HUNSPELL_LIBS="${filteredlibs}"
@@ -9596,7 +9601,7 @@ else
if test "$COM" = "MSC"; then
HUNSPELL_LIBS="${WORKDIR}/LinkTarget/StaticLibrary/hunspell.lib"
else
- HUNSPELL_LIBS="-L${WORKDIR}/UnpackedTarball/hunspell/src/hunspell/.libs -lhunspell-1.4"
+ HUNSPELL_LIBS="-L${WORKDIR}/UnpackedTarball/hunspell/src/hunspell/.libs -lhunspell-1.6"
fi
BUILD_TYPE="$BUILD_TYPE HUNSPELL"
fi