summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-07 10:43:14 +0100
committerStephan Bergmann <sbergman@redhat.com>2018-11-08 13:36:53 +0100
commit4613e105f98af6e3b65ce87432b1a2db45e71ae2 (patch)
treeaebe58663f3a8442c5874cdc5e2ecf6513f5987b /configure.ac
parentac16fe01ad7bd0f48a398f6d5ca4475eff7e2068 (diff)
tdf#121131: Default COMPILER_PLUGINS_CXX to g++ -std=c++11
ab8bf5533f8de9bb1aa9dc83e650e4eccf0fcac3 "Avoid error message from configure about clang's header for compiler plugins" caused problems after cd472d1d8489f30797f47d3f6dafede28c1feb90 "Compile as C++2a, where available", when the compiler used to build LO (CXX) supports -std=gnu++2a but the compiler used to build loplugin (COMPILER_PLUGINS_CXX) does not. So solve that problem instead by just adding -std=c++11 to the default for COMPILER_PLUGINS_CXX. Change-Id: I95e86bc28f2a0dfb2b7bdce6b15955b870428b8c Reviewed-on: https://gerrit.libreoffice.org/62997 Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de> Reviewed-by: Luboš Luňák <l.lunak@collabora.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f6ba4a013d94..145505c6e390 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6723,9 +6723,9 @@ if test "$COM_IS_CLANG" = "TRUE"; then
save_CPPFLAGS=$CPPFLAGS
save_CXX=$CXX
# compiler plugins must be built with "native" compiler that was used to build Clang itself:
- : "${COMPILER_PLUGINS_CXX=g++}"
+ : "${COMPILER_PLUGINS_CXX=g++ -std=c++11}"
CXX=$COMPILER_PLUGINS_CXX
- CPPFLAGS="$CPPFLAGS $CXXFLAGS_CXX11 -I$CLANGDIR/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
+ CPPFLAGS="$CPPFLAGS -I$CLANGDIR/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
AC_CHECK_HEADER(clang/AST/RecursiveASTVisitor.h,
[COMPILER_PLUGINS=TRUE],
[