summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2016-11-10 11:52:55 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2016-11-10 12:00:42 +0100
commit3e522fcbaad0848a2fb4d4d5a5c0bfe81475249d (patch)
tree587205d5537c53ad519d1a3f778ee05dac6b63e0 /configure.ac
parent61f760d2c4ce97fc3f0f533cd2989ea2aad33276 (diff)
demote "unknown android ndk" to warning only (and add 13.1 as known)
android studio/sdk manager doesn't provide a default way to install multiple versions of the NDK, so typically only the latest one will be available. Don't make configure error out in this case, but print a warning instead. Change-Id: I6af9a3f088daf7d12ebd9910286d7f44d264014a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5c11dc627507..1c1c87f3b204 100644
--- a/configure.ac
+++ b/configure.ac
@@ -361,14 +361,17 @@ if test -n "$with_android_ndk"; then
else
ANDROID_NDK_VERSION=`cut -f1 -d' ' <$ANDROID_NDK_HOME/RELEASE.TXT`
fi
-
+ if test -z "$ANDROID_NDK_VERSION"; then
+ AC_MSG_ERROR([Failed to determine android NDK version. Please check your installation.])
+ fi
case $ANDROID_NDK_VERSION in
r9*|r10*)
;;
- 11.1.*|12.1.*)
+ 11.1.*|12.1.*|13.1.*)
;;
*)
- AC_MSG_ERROR([Unsupported NDK version $ANDROID_NDK_VERSION, only r9*, r10*, 11.1.* and 12.1.* are supported])
+ AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 13.1.* have been used successfully. Proceed at your own risk.])
+ add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 13.1.* have been used successfully. Proceed at your own risk."
;;
esac