summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBjoern Michaelsen <bjoern.michaelsen@canonical.com>2012-12-10 19:06:48 +0100
committerBjoern Michaelsen <bjoern.michaelsen@canonical.com>2012-12-10 19:08:27 +0100
commit3c64d866379c3ae78b95b68fffe62685037da707 (patch)
treeae72152f628bb8896afcb574b2763f60aa3fa1ab /configure.ac
parentc74fe188b178fab821084bb82d4574f77dc2e1ce (diff)
no need for wget/curl when not fetching anything
Change-Id: I097675450a0eed87eccf90356c81657485609d13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index caac6596c978..2b12bca2a283 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11753,6 +11753,10 @@ AC_SUBST(SCPDEFS)
#
WGET=
MD5SUM=
+CURL=
+
+if test "$enable_fetch_external" != "no"; then
+
CURL=`which curl 2>/dev/null`
for i in wget /usr/bin/wget /usr/local/bin/wget /usr/sfw/bin/wget /opt/sfw/bin/wget /opt/local/bin/wget; do
@@ -11794,6 +11798,8 @@ if test -z "$MD5SUM"; then
add_warning "no md5sum: found!"
fi
+fi
+
AC_SUBST(WGET)
AC_SUBST(CURL)
AC_SUBST(MD5SUM)