summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2016-09-28 08:52:45 +0200
committerStephan Bergmann <sbergman@redhat.com>2016-09-30 07:11:24 +0000
commit281bd0b08a1c678209befd2355c29d823a2e85d3 (patch)
treedad4508473ca77ac520def260ed68f093f52abed /configure.ac
parent4d87443bf59c3242d58b56cc1583d73213ae1f2f (diff)
Update HarfBuzz to 1.3.2
* Only build the library, makes no-freetype patch redundant. * Don’t build ICU support as a separate library, otherwise we would also build the alternative UCDN Unicode functions which we do not use. * Don’t build FontConfig support stuff that was added a few releases ago as we don’t need it as well. Change-Id: Ia5f296c61a6ce2a589b1c521b3c2c7c75dbcf74d Reviewed-on: https://gerrit.libreoffice.org/29342 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 97e6e0f2c9d2..56f5ebe6a15b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9341,9 +9341,9 @@ if test "$with_harfbuzz" = "yes" -o \( $_os != WINNT -a $_os != Darwin -a $_os !
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18],["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz -lharfbuzz-icu"])
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18],["-I${WORKDIR}/UnpackedTarball/harfbuzz/src"],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
else
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10],[-I${WORKDIR}/UnpackedTarball/harfbuzz/src],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz -lharfbuzz-icu"])
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10],[-I${WORKDIR}/UnpackedTarball/harfbuzz/src],["-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"])
fi
else
AC_MSG_RESULT([no])