summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-05-10 10:13:51 +0300
committerTor Lillqvist <tml@iki.fi>2013-05-10 18:55:03 +0300
commit1feb672b5e8614cd6d01c1f167f8523a37c62bf5 (patch)
treef5788df286c4ddd3b573085dfec7b91c2b0707c6 /configure.ac
parent8fa7b8234f5b5a0f30972a3ece939363fff4fdae (diff)
Use bundled OpenSSL when building for OS X 10.7 or later
http://stackoverflow.com/questions/7406946/why-is-apple-deprecating-openssl-in-macos-10-7-lion http://stackoverflow.com/questions/7475914/libcrypto-deprecated-on-mac-os-x-10-7-lion Apple apparently got fed up with the unstable ABI of OpenSSL, or something, and recommend you either move to their "Common Crypto Architecture", or, if you have to stay with OpenSSL, just build it yourself statically and bundle with your application. So let's do that. Change-Id: I5f19fcce9b4e00ff2ce3089a2398b3f08f76a9a0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index df8576527c11..9871f4ca573a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8654,7 +8654,21 @@ DISABLE_OPENSSL="NO"
AC_MSG_CHECKING([whether to disable OpenSSL usage])
if test "$enable_openssl" = "yes"; then
AC_MSG_RESULT([no])
- if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o \
+ if test $_os = Darwin -a $MAC_OS_X_VERSION_MIN_REQUIRED -ge 1070; then
+ # OpenSSL is deprecated when building for 10.7 or later.
+ #
+ # http://stackoverflow.com/questions/7406946/why-is-apple-deprecating-openssl-in-macos-10-7-lion
+ # http://stackoverflow.com/questions/7475914/libcrypto-deprecated-on-mac-os-x-10-7-lion
+ #
+ # They apparently got fed up with the unstable ABI of
+ # OpenSSL, or something, and recommend you either move to
+ # their "Common Crypto Architecture", or, if you have to stay
+ # with OpenSSL, just build it yourself statically and bundle
+ # with your application.
+
+ with_system_openssl=no
+ libo_CHECK_SYSTEM_MODULE([openssl],[OPENSSL],[openssl])
+ elif test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" -o \
"$_os" = "DragonFly" && test "$with_system_openssl" != "no"; then
# Mac OS builds should get out without extra stuff is the Mac porters'
# wish. And pkg-config is although Xcode ships a .pc for openssl