summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2012-12-07 17:51:21 +0100
committerLuboš Luňák <l.lunak@suse.cz>2012-12-07 19:48:16 +0100
commit1aad4689babec28f47b99666b303ab8bfffc3106 (patch)
tree04e82f39d983dfedfdbf25331380456187e096e7 /configure.ac
parente56c274f815a9b0cc55489537fad8c59273d2c94 (diff)
use config_xxx.h files instead of -DHAVE_XXX on the command line
As the latter does not quite scale, and also source files depending on the setting/feature did not rebuild in case of a change. There are intentionally more config_xxx.h files (so autoheader from autotools is not used), so that a setting change does not force automatically a rebuild of everything. Running configure does not touch those config_xxx.h files that have not changed. There's config/README with a howto. Change-Id: I6d6e82050ff8faf5364ed246848b8401aca3e0e5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0178d4c797c..9a0d449c26c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5579,6 +5579,7 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([broken (i.e., no)])
else
HAVE_THREADSAFE_STATICS=TRUE
+ AC_DEFINE(HAVE_THREADSAFE_STATICS)
AC_MSG_RESULT([yes])
fi
else
@@ -5646,6 +5647,7 @@ if test "$GCC" = "yes"; then
]])],[HAVE_GCC_BUILTIN_ATOMIC=TRUE],[])
if test "$HAVE_GCC_BUILTIN_ATOMIC" = "TRUE"; then
AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_GCC_BUILTIN_ATOMIC)
else
AC_MSG_RESULT([no])
fi
@@ -5692,6 +5694,7 @@ return !(i != 0 && j != 0);
fi
if test "$HAVE_CXX0X" = "TRUE"; then
AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_CXX0X])
else
AC_MSG_RESULT([no])
fi
@@ -5864,6 +5867,7 @@ void test( ... );
AC_MSG_RESULT([$sfinae_anonymous_broken])
if test "$sfinae_anonymous_broken" = "yes"; then
HAVE_SFINAE_ANONYMOUS_BROKEN="TRUE"
+ AC_DEFINE(HAVE_SFINAE_ANONYMOUS_BROKEN)
fi
AC_LANG_POP([C++])
fi
@@ -9432,6 +9436,7 @@ fi
ENABLE_GTK=""
if test "x$enable_gtk" = "xyes"; then
ENABLE_GTK="TRUE"
+ AC_DEFINE(ENABLE_GTK)
R="gtk $R"
fi
AC_SUBST(ENABLE_GTK)
@@ -9444,6 +9449,7 @@ if test "x$enable_tde" = "xyes"; then
AC_MSG_ERROR([enabling both KDE and TDE is not supported])
fi
ENABLE_TDE="TRUE"
+ AC_DEFINE(ENABLE_TDE)
R="$R tde"
fi
AC_SUBST(ENABLE_TDE)
@@ -9451,6 +9457,7 @@ AC_SUBST(ENABLE_TDE)
ENABLE_KDE=""
if test "x$enable_kde" = "xyes"; then
ENABLE_KDE="TRUE"
+ AC_DEFINE(ENABLE_KDE)
R="$R kde"
fi
AC_SUBST(ENABLE_KDE)
@@ -9458,6 +9465,7 @@ AC_SUBST(ENABLE_KDE)
ENABLE_KDE4=""
if test "x$enable_kde4" = "xyes"; then
ENABLE_KDE4="TRUE"
+ AC_DEFINE(ENABLE_KDE4)
R="$R kde4"
fi
AC_SUBST(ENABLE_KDE4)
@@ -9671,6 +9679,7 @@ TELEPATHY_LIBS=""
AC_MSG_CHECKING([whether to enable Telepathy support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_telepathy" = "yes"; then
ENABLE_TELEPATHY="TRUE"
+ AC_DEFINE(ENABLE_TELEPATHY)
AC_MSG_RESULT([yes])
PKG_CHECK_MODULES( TELEPATHY, telepathy-glib >= 0.18.0 glib-2.0 gobject-2.0 gthread-2.0 gio-2.0 )
else
@@ -12461,6 +12470,9 @@ else
fi
AC_CONFIG_FILES([config_host.mk])
+AC_CONFIG_HEADERS([config/config_global.h])
+AC_CONFIG_HEADERS([config/config_telepathy.h])
+AC_CONFIG_HEADERS([config/config_vclplug.h])
AC_OUTPUT
# touch the config timestamp file