summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2016-09-27 11:53:56 +0200
committerMichael Stahl <mstahl@redhat.com>2016-09-27 11:56:28 +0200
commit16c0807d75cfd9ecbca9c703ed0eadda80529aab (patch)
tree0046ccfa170d83e32a190cbe3f48bd97eb9dd2ae /configure.ac
parent9a5b10544a11df3c0b08532a9143cd9adced4a4d (diff)
configure: reject Apple JDK
Since commit 32bc8ddbf335dd26019edcf12758643b4cff9913 the jvmfwk rejects Apple JDK and while the Java code builds fine with it, various tests such as CppunitTest_dbaccess_hsqldb_test fail if it is the only installed JRE. The simplest way to avoid the problem is to not allow building with Apple JDK. Change-Id: I5701e38cffded4596ac94608867a038ff76f75ec
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 10c987b87b6b..e02559d293e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7100,6 +7100,13 @@ _ACEOF
# now check if $JAVA_HOME is really valid
if test "$_os" = "Darwin" -o "$OS_FOR_BUILD" = MACOSX; then
+ case "${JAVA_HOME}" in
+ /Library/Java/JavaVirtualMachines/*)
+ ;;
+ *)
+ AC_MSG_ERROR([JDK in $JAVA_HOME cannot be used in CppUnit tests - install Oracle JDK])
+ ;;
+ esac
if test ! -f "$JAVA_HOME/lib/jvm.cfg" -a "x$with_jdk_home" = "x"; then
JAVA_HOME_OK="NO"
fi