summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2017-02-10 12:27:07 +0000
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-03-14 12:00:14 +0100
commit08f0a54644c52a2c3da3b900ecf916639129e914 (patch)
treeab13b33271ba2cc52f7562ea8d0597b8d232ff41 /configure.ac
parent5297b1f14afdc88317b8937070c3cfaee8e2fa88 (diff)
add --disable-pdfium
(cherry picked from commit 55e203a0c6c8c6f0c58025efd7c9079e27b438c9) Conflicts: configure.ac distro-configs/LibreOfficeOssFuzz.conf Change-Id: I9137dc0030c3c752ffc0931721bf6b0013309d39
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 23d9adcd475d..0711a700b048 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1035,6 +1035,11 @@ AC_ARG_ENABLE(pdfimport,
[Disable building the PDF import feature.])
)
+AC_ARG_ENABLE(pdfium,
+ AS_HELP_STRING([--disable-pdfium],
+ [Disable building PDFium.])
+)
+
###############################################################################
dnl ---------- *** ----------
@@ -10678,6 +10683,18 @@ AC_SUBST(SYSTEM_POPPLER)
AC_SUBST(POPPLER_CFLAGS)
AC_SUBST(POPPLER_LIBS)
+# pdf import?
+AC_MSG_CHECKING([whether to build PDFium])
+ENABLE_PDFIUM=
+if test -z "$enable_pdfium" -o "$enable_pdfium" = yes; then
+ AC_MSG_RESULT([yes])
+ ENABLE_PDFIUM=TRUE
+ BUILD_TYPE="$BUILD_TYPE PDFIUM"
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_PDFIUM)
+
AC_MSG_CHECKING([whether to build the Wiki Publisher extension])
if test "x$enable_ext_wiki_publisher" = "xyes" -a "x$enable_extension_integration" != "xno" -a "$with_java" != "no"; then
AC_MSG_RESULT([yes])