summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-09-12 11:32:46 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-09-12 13:31:55 +0200
commit0295ff316336f50a2db04c1e295368ff4d99abe8 (patch)
tree97e6b94cffdf776d82769021044369f962a7eaeb /configure.ac
parent569f7a4adefdfce9be82499d8449e808bfad06c6 (diff)
Use only exact --with-macosx-sdk=..., if explicitly requested
Change-Id: Ifacf22dd283d2d90d68cfe9edc45f8f5e24f08bf Reviewed-on: https://gerrit.libreoffice.org/60374 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 685408e99062..e46ef61e61db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2713,7 +2713,7 @@ if test $_os = Darwin -o $_os = iOS; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in $with_macosx_sdk 10.13 10.12; do
+ for _macosx_sdk in ${with_macosx_sdk-10.13 10.12}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2727,7 +2727,7 @@ if test $_os = Darwin -o $_os = iOS; then
fi
done
if test ! -d "$MACOSX_SDK_PATH"; then
- AC_MSG_ERROR([Could not figure out the location of a Mac OS X SDK and its version])
+ AC_MSG_ERROR([Could not find an appropriate Mac OS X SDK])
fi
if test $_os = iOS; then