summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatteo Casalin <matteo.casalin@gmx.com>2012-11-10 22:14:47 +0100
committerTor Lillqvist <tml@iki.fi>2012-11-11 08:05:14 +0000
commite7037b2e7e487d6075d17fcff7cd95a6e98700c0 (patch)
treeff40c1c48be251784ac4bd566273cdbce3743890 /configure.ac
parentcee6c4b193eff4f499e60867766c13fda3818239 (diff)
Kill set_oenv remnants (by just renaming the required timestamp file)
Change-Id: I779128111a4f69235a4c8cc6510018fc61d1b24b Reviewed-on: https://gerrit.libreoffice.org/1026 Tested-by: Tor Lillqvist <tml@iki.fi> Reviewed-by: Tor Lillqvist <tml@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index c968dc2e19ef..c75c082ebbba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2903,7 +2903,7 @@ if test "$GCC" = "yes"; then
if test "$_os" = "Darwin" -a "$with_macosx_sdk" = "10.4" -a "$GCCVER" -ge "040100"; then
if test -z "$save_CC" -a -x "$GCC_HOME/bin/gcc-4.0"; then
export CC="$GCC_HOME/bin/gcc-4.0"
- # export CC to have it available in set_soenv -> config.guess
+ # export CC to make it finally available to config.guess
GCCVER2=`$CC -dumpversion | $AWK -F. '{ print \$1*10000+\$2*100+\$3 }'`
if test "$GCCVER2" -ge "040000" -a "$GCCVER2" -lt "040100"; then
GCCVER=$GCCVER2
@@ -3215,8 +3215,7 @@ if test "$_os" = "WINNT"; then
fi
AC_SUBST(BUILD_X64)
- # These are passed to the environment through set_soenv.in as usual, and then
- # used in set_wntx64.mk
+ # These are passed to the environment and then used in set_wntx64.mk
AC_SUBST(CXX_X64_BINARY)
AC_SUBST(LINK_X64_BINARY)
AC_SUBST(LIBMGR_X64_BINARY)
@@ -12524,13 +12523,13 @@ fi
AC_CONFIG_FILES([config_host.mk ooo.lst])
AC_OUTPUT
-# touch the config timestamp file set_soenv.stamp
-if test ! -f set_soenv.stamp; then
- echo > set_soenv.stamp
+# touch the config timestamp file
+if test ! -f config_host.mk.stamp; then
+ echo > config_host.mk.stamp
elif diff config_host.mk config_host.mk.last >/dev/null 2>&1; then
echo "Configuration unchanged - avoiding scp2 stamp update"
else
- echo > set_soenv.stamp
+ echo > config_host.mk.stamp
fi