summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-28 00:13:55 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-28 00:17:37 +0200
commitaeb1c38c8c6dd2b092102c5f6ee5749f5b6c15cb (patch)
tree52f523573dd9d44d48c5e2599d1c9c5d3f32cb1b /configure.ac
parent0cd2accbd4cb044bf67b75e5271aa7f39628349c (diff)
Do disable extensions for Android, too
I started running into mysterious trouble when some code still thought it should be looking for extensions, although (perhaps) other code was not willing to support such, or something. Some confusion caused by my recent changes to make the conditional support of features more fine-grained. Change-Id: I61758cb06054ceb038d200bc95615b5b85ed0f7b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 970ae68b74e6..5fef5418f477 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2150,9 +2150,8 @@ fi
AC_SUBST(DISABLE_DBCONNECTIVITY)
if test -z "$enable_extensions"; then
- # For iOS disable extensions unless specifically overridden with
- # --enable-extensions.
- if test $_os != iOS; then
+ # For iOS and Android disable extensions unless specifically overridden with --enable-extensions.
+ if test $_os != iOS -a $_os != Android; then
enable_extensions=yes
fi
fi