summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-27 12:56:59 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-27 13:02:22 +0200
commitab7ac5884c5a824999b58d2a800cae64cb8e359a (patch)
tree868891d9f5678e6df6a6f527541d0d933c69a98f /configure.ac
parent71907bb06ae6fc3c0ea1485b6ed0efaed196a57a (diff)
Use <config_features.h> instead of -DDISABLE_EXTENSIONS
Change-Id: I4fe5cd27b77d44b9b33af0ae3c3754e3b85c2ca3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6647b05d7693..970ae68b74e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2157,13 +2157,10 @@ if test -z "$enable_extensions"; then
fi
fi
-DISABLE_EXTENSIONS=''
if test "$enable_extensions" = yes; then
BUILD_TYPE="$BUILD_TYPE EXTENSIONS"
-else
- DISABLE_EXTENSIONS='TRUE'
+ AC_DEFINE(HAVE_FEATURE_EXTENSIONS)
fi
-AC_SUBST(DISABLE_EXTENSIONS)
if test -z "$enable_scripting"; then
# Disable scripting for iOS unless specifically overridden
@@ -2659,7 +2656,7 @@ AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
AC_MSG_CHECKING([whether to treat the installation as read-only])
if test \( -z "$enable_readonly_installset" -a "$ENABLE_MACOSX_SANDBOX" = YES \) -o \
- "$DISABLE_EXTENSIONS" = TRUE; then
+ "$enable_extensions" != yes; then
enable_readonly_installset=yes
fi
if test "$enable_readonly_installset" = yes; then