summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2018-04-23 16:41:51 +0200
committerAndras Timar <andras.timar@collabora.com>2020-05-04 22:42:23 +0200
commita3c8945bd16472b473820e67bb86509d768d1caf (patch)
treeba83f57c878393f7e062cd892a823609bbd1b2a6 /configure.ac
parentb48c1a32bfbdf83e28a3bd53655b54ad45e7abe0 (diff)
[cp] Optionally bundle even more Google Noto fonts
Change-Id: I6c08476710ab541ff9b9407f5d874dbb038990df
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6de6ae246e56..32cbef9c1719 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1602,6 +1602,11 @@ libo_FUZZ_ARG_WITH(fonts,
known to be available on the system then you should use this option.]),
,)
+AC_ARG_ENABLE(noto-font,
+ AS_HELP_STRING([--enable-noto-font],
+ [Add more Google Noto fonts.]),
+,)
+
AC_ARG_WITH(epm,
AS_HELP_STRING([--with-epm],
[Decides which epm to use. Default is to use the one from the system if
@@ -11614,6 +11619,19 @@ else
fi
AC_SUBST(WITH_FONTS)
+dnl Test whether to include more Google Noto fonts
+dnl ===================================================================
+AC_MSG_CHECKING([whether to include more Google Noto fonts])
+if test "$enable_noto_font" = "" -o "$enable_noto_font" = "no" -o "$with_fonts" = "no"; then
+ AC_MSG_RESULT([no])
+ WITH_NOTO_FONT=
+else
+ AC_MSG_RESULT([yes])
+ WITH_NOTO_FONT=TRUE
+ BUILD_TYPE="$BUILD_TYPE NOTO_FONT"
+ SCPDEFS="$SCPDEFS -DWITH_NOTO_FONT"
+fi
+AC_SUBST(WITH_NOTO_FONT)
dnl ===================================================================
dnl Test whether to enable online update service