summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-11-09 19:29:05 +0100
committerMichael Stahl <mstahl@redhat.com>2012-11-09 19:29:47 +0100
commit89f80c167112837346ec5a63873f620a07a76493 (patch)
tree7f6490039edfbe6305d72ef88a6863b046989aa2 /configure.ac
parent7b213e05a4f6aecd8b5388fb8fa8cec355302b07 (diff)
configure: why not set up VALGRIND_CFLAGS all in one place
Also unbreaks the build because VALGRIND_CFLAGS is now never empty with cedd9ebdd260e99e74ad54391c0d0b1d1ebd9891. Change-Id: Ide5ca799b3656ccaff483ca05dbc18682136345f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c968dc2e19ef..77a6011b7e5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5058,6 +5058,7 @@ if test "$cross_compiling" != "yes" -a -n "$ENABLE_DBGUTIL" -a \
AC_CHECK_HEADER([memcheck.h], [], [VALGRIND_CFLAGS=""])
fi
CPPFLAGS=$prev_cppflags
+ VALGRIND_CFLAGS="${VALGRIND_CFLAGS} -DHAVE_MEMCHECK_H=1"
fi
AC_SUBST([VALGRIND_CFLAGS])