summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-27 09:22:38 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-27 11:36:03 +0200
commit556fe2c6128a32233b411a85c54177e1d5be1e0d (patch)
tree6a926732bd15a99205c9eab047d22139a7b7ca61 /configure.ac
parentf174c972ac3ef93804a28f9566559382697832f9 (diff)
Add config_features.h platform or configurable high-level features
Defines HAVE_FEATURE_{DESKTOP,HELP,MULTIUSER_ENVIRONMENT} for now. Using <config_features.h> will supersede checking the LIBO_FEATURE_DESKTOP and LIBO_FEATURE_HELP passed on the compilation command-line. Change-Id: I9866e2fd142f5c1a64c8f5c74452a20de23c66e3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4899b2ba7c7b..6647b05d7693 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2106,6 +2106,8 @@ dnl cross-compiling would imply a non-desktop OS.
if test $_os != iOS -a $_os != Android; then
BUILD_TYPE="$BUILD_TYPE DESKTOP"
+ AC_DEFINE(HAVE_FEATURE_DESKTOP)
+ AC_DEFINE(HAVE_FEATURE_MULTIUSER_ENVIRONMENT)
fi
DISABLE_EXPORT=''
@@ -4388,6 +4390,7 @@ AC_MSG_CHECKING([whether to build help])
if test "$with_help" = "yes" -a $_os != iOS -a $_os != Android; then
AC_MSG_RESULT([yes])
BUILD_TYPE="$BUILD_TYPE HELP"
+ AC_DEFINE(HAVE_FEATURE_HELP)
SCPDEFS="$SCPDEFS -DWITH_HELP"
GIT_NEEDED_SUBMODULES="helpcontent2 $GIT_NEEDED_SUBMODULES"
else
@@ -11863,6 +11866,7 @@ fi
AC_CONFIG_FILES([config_host.mk Makefile lo.xcent instsetoo_native/util/openoffice.lst])
AC_CONFIG_HEADERS([config_host/config_clang.h])
+AC_CONFIG_HEADERS([config_host/config_features.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])