summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-14 09:29:20 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-14 09:29:37 +0200
commit1d559d9e386591551baec14ef5eae9bacf7a0d97 (patch)
treef4219ebecfcabaf3792b1d6de4a952a099933bb2 /configure.ac
parente581b9bd1cd06900efa27debbf073282b9d0908f (diff)
Add some comments
Change-Id: I3cc92e3fe471fa92a9de339c7677d866e46ab185
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 61b92ad1aece..175d894ade34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,7 +163,12 @@ if test -n "$with_android_ndk"; then
android_cpu=x86
fi
- # Check if there is a (self-built) 64-bit tool-chain
+ # Check if there is a (self-built) 64-bit tool-chain. Google does not provide 64-bit binaries of
+ # the NDK tool-chain, sigh, but it is easy to build one yourself. Using a 64-bit linker is
+ # required if you compile everything with -g. A 32-bit linker just won't manage to link the
+ # (app-specific) single huge .so that is built for the apps in android/experimental/*. (A 64-bit
+ # ld.gold grows to over 10 gigabytes of virtual space when linking such a .so where all objects
+ # have been built with debug information.)
toolchain_system='*'
if test $build_os = linux-gnu; then
case $build_cpu in