summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-03-23 08:02:33 +0200
committerTor Lillqvist <tml@iki.fi>2013-03-23 08:03:57 +0200
commit0fddd7aa822abc86b646939e292dbcce0014db08 (patch)
tree70e22c7f821965f19b741325f7218187bf1c4928 /configure.ac
parent00050e3799690a45c406429740e7b362e5f3e89d (diff)
The x86 NDK toolchain uses a different naming convention for its root
Blind fix attempt for the Android-X86 tinderbox. Change-Id: Ib7ae0d077aad149d27c19f1b0137bb87062d0f60
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b9b11f62f597..e24efcc2bc64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,21 +162,24 @@ if test -n "$with_android_ndk"; then
if test $host_cpu = arm; then
android_cpu=arm
+ android_platform_prefix=$android_cpu-linux-androideabi
elif test $host_cpu = mips; then
android_cpu=mips
+ android_platform_prefix=$android_cpu-linux-androideabi
else
# host_cpu is something like "i386" or "i686" I guess, NDK uses
# "x86" in some contexts
android_cpu=x86
+ android_platform_prefix=$android_cpu
fi
case "$with_android_ndk_toolchain_version" in
4.6|4.7)
- ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_cpu-linux-androideabi-$with_android_ndk_toolchain_version
+ ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-$with_android_ndk_toolchain_version
ANDROID_COMPILER_DIR=$ANDROID_BINUTILS_DIR
;;
clang3.1|clang3.2)
- ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_cpu-linux-androideabi-4.6
+ ANDROID_BINUTILS_DIR=$ANDROID_NDK_HOME/toolchains/$android_platform_prefix-4.6
ANDROID_COMPILER_DIR=$ANDROID_NDK_HOME/toolchains/llvm-${with_android_ndk_toolchain_version#clang}
ANDROID_USING_CLANG=true
;;