summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-11-08 14:38:57 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-11-08 15:05:10 +0200
commit0ab6421028ba715dfc7c152d0185333e0a5f79f9 (patch)
treeb3d4983bffd56dbb26e226211193dadcb835dfe6 /configure.ac
parentbc5cff54c3965e526657a4a4b4637e68a36f5e52 (diff)
Use -ffunction-sections for Android
Part of work towards making the linker more eager to drop unused functions from the output file. Change-Id: Id4edb50ef4048f02277a13885b5f81707cb9c8a3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef6a3d8bfebc..08295142176d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,7 @@ if test -n "$with_android_ndk"; then
ANDROID_APP_ABI=x86
ANDROIDCFLAGS="-march=atom"
fi
+ ANDROIDCFLAGS="$ANDROIDCFLAGS -ffunction-sections"
ANDROIDCFLAGS="$ANDROIDCFLAGS -Wno-psabi --sysroot $ANDROID_NDK_HOME/platforms/android-9/arch-$android_cpu -L$ANDROID_NDK_HOME/sources/cxx-stl/gnu-libstdc++/${ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR}libs/$ANDROID_APP_ABI"
# When using the 4.6 or newer toolchain, use the gold linker