summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2013-03-24 17:48:48 -0400
committerPeter Foley <pefoley2@verizon.net>2013-03-24 18:25:04 -0400
commit02ed2608199f2adc466849d0f4864213ad07c445 (patch)
tree47bfaeea72024cf1bb4a11f285cd2b9e71aaf3cf /configure.ac
parentdb754e891e35a2832645fce676a5f6f0bf162976 (diff)
add configure option to use clang
Change-Id: Ide63ef8bde7ed739b9bf29e936c01e156e8e3de4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 35 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 6a31c894d767..898dedb0523b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1158,6 +1158,11 @@ AC_ARG_ENABLE(winegcc,
needed for MinGW cross-compilation.]),
)
+AC_ARG_ENABLE(clang,
+ AS_HELP_STRING([--enable-clang],
+ [Build using the clang compiler.]),
+)
+
AC_ARG_ENABLE(liblangtag,
AS_HELP_STRING([--disable-liblangtag],
[Disable use of liblangtag, and insted use an own simple
@@ -2274,43 +2279,36 @@ if test "$CCACHE" != ""; then
fi
dnl ===================================================================
+dnl Checks for Icecream
+dnl ===================================================================
+if test "$enable_icecream" = "yes"; then
+ if test -d "/usr/lib/icecc/bin"; then
+ ICECREAM_HOME="/usr/lib/icecc/"
+ else
+ ICECREAM_HOME="/opt/icecream/"
+ fi
+ if test -z "$CC"; then
+ CC="$GCC_HOME/bin/gcc"
+ fi
+ if test -z "$CXX"; then
+ CXX="$GCC_HOME/bin/g++"
+ fi
+fi
+
+dnl ===================================================================
dnl Checks for C compiler,
+dnl AC_PROG_CC checks for gcc, cc and then cl (if it weren't guarded for win32)
dnl The check for the C++ compiler is later on.
dnl ===================================================================
-if test "$_os" != "WINNT" -a "$WITH_MINGW" != "yes"; then
- GCC_HOME_SET="true"
- AC_MSG_CHECKING([gcc home])
- if test -z "$with_gcc_home"; then
- if test "$enable_icecream" = "yes"; then
- if test -d "/usr/lib/icecc/bin"; then
- GCC_HOME="/usr/lib/icecc/"
- else
- GCC_HOME="/opt/icecream/"
- fi
- else
- GCC_HOME=`which gcc | $SED -e s,/bin/gcc,,`
- GCC_HOME_SET="false"
- fi
- else
- GCC_HOME="$with_gcc_home"
- fi
- AC_MSG_RESULT($GCC_HOME)
- AC_SUBST(GCC_HOME)
-
- if test "$GCC_HOME_SET" = "true"; then
- if test -z "$CC"; then
- CC="$GCC_HOME/bin/gcc"
- fi
- if test -z "$CXX"; then
- CXX="$GCC_HOME/bin/g++"
- fi
- fi
-fi
-
-dnl The following checks for gcc, cc and then cl (if it weren't guarded for win32)
if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
# AC_PROG_CC sets CFLAGS to -g -O2 if not set, avoid that
save_CFLAGS=$CFLAGS
+ if test "$enable_clang" = "yes"; then
+ AC_PATH_PROG(CC,clang)
+ if test -z "$CC"; then
+ AC_MSG_ERROR([Clang not found in path. Is it installed?])
+ fi
+ fi
AC_PROG_CC
CFLAGS=$save_CFLAGS
fi
@@ -5002,6 +5000,12 @@ dnl ===================================================================
if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
# AC_PROG_CXX sets CXXFLAGS to -g -O2 if not set, avoid that
save_CXXFLAGS=$CXXFLAGS
+ if test "$enable_clang" = "yes"; then
+ AC_PATH_PROG(CXX,clang++)
+ if test -z "$CXX"; then
+ AC_MSG_ERROR([clang++ not found in path. Is it installed?])
+ fi
+ fi
AC_PROG_CXX
CXXFLAGS=$save_CXXFLAGS
else