summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFridrich Štrba <fridrich.strba@bluewin.ch>2012-12-07 09:40:39 +0100
committerFridrich Štrba <fridrich.strba@bluewin.ch>2012-12-07 09:41:23 +0100
commitd25f291000b37d52c24321972633a46d53645a5b (patch)
tree69719c33b1cbf4fb77eba7495db311fa3af8c332 /configure.ac
parentae7bd9518db7e2ace69f3d4f7619ac107722e6b5 (diff)
Add --enable-windows-build-signing option
Change-Id: I9630a486043c97aa9e31873c63f807cedb869a24 Signed-off-by: Fridrich Štrba <fridrich.strba@bluewin.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8b38a782333..ad5e9f357eb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1065,6 +1065,11 @@ AC_ARG_ENABLE(release-build,
See http://wiki.documentfoundation.org/DevBuild]),
,)
+AC_ARG_ENABLE(windows-build-signing,
+ AS_HELP_STRING([--enable-windows-build-signing],
+ [Enable signing of windows binaries (*.exe, *.dll)]),
+,)
+
AC_ARG_ENABLE(silent-msi,
AS_HELP_STRING([--enable-silent-msi],
[Enable MSI with LIMITUI=1 (silent install).]),
@@ -2112,6 +2117,19 @@ fi
AC_SUBST(ENABLE_RELEASE_BUILD)
dnl ===================================================================
+dnl Test whether to sign Windows Build
+dnl ===================================================================
+AC_MSG_CHECKING([whether to sign windows build])
+if test "$enable_windows_build_signing" = "yes" -a "$_os" = "WINNT" -a "$WITH_MINGW" != "YES" ; then
+ AC_MSG_RESULT([yes])
+ WINDOWS_BUILD_SIGNING="TRUE"
+else
+ AC_MSG_RESULT([no])
+ WINDOWS_BUILD_SIGNING="FALSE"
+fi
+AC_SUBST(WINDOWS_BUILD_SIGNING)
+
+dnl ===================================================================
dnl MacOSX build and runtime environment options
dnl ===================================================================