summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-11-28 20:52:32 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-11-28 20:53:44 +0200
commitc87389c7680481da2a96d4f4e0615913f0054da9 (patch)
tree3558284219a4cbdc23f69971ce8d8193f83060c3 /configure.ac
parent13fa5d94f287f6e6bba767bd491731667f921b48 (diff)
Add comment about Windows SDK 8
Change-Id: I91abacdbe75b36a61e110068e300c54c08c7ead2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b21a59b32bdb..5ebf6ff496e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8997,8 +8997,22 @@ if test "$_os" = "WINNT"; then
WINDOWS_SDK_HOME=`cygpath -d "$WINDOWS_SDK_HOME"`
WINDOWS_SDK_HOME=`cygpath -u "$WINDOWS_SDK_HOME"`
- #If this sdk is incomplete, lets see if the one
- #recommended to be installed is available
+ # If this sdk is incomplete, lets see if the one
+ # recommended to be installed is available.
+
+ # This refers to the Windows SDK 8 (as distributed
+ # with Visual Studio 2012, or maybe also
+ # separately), I assume.
+
+ # I wouldn't say that it is "incomplete", it is
+ # just structured differtently. We do seem to try
+ # to adapt to that structure below (look for the
+ # Include/um etc stuff), so rejecting it here is a
+ # bit premature... *but* then one notices that
+ # compiling with MSVS2008 and trying to use SDK 8
+ # leads to horrible errors in ICU at least. Oh
+ # well.
+
if test ! -x "$WINDOWS_SDK_HOME/bin/msiinfo.exe"; then
WINDOWS_SDK7_HOME=`cat "/proc/registry/HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/Windows/v7.1/InstallationFolder" 2> /dev/null | tr '\000' '\n' | head -n 1`
if test -n "$WINDOWS_SDK7_HOME"; then