summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-11-29 11:27:45 +0100
committerStephan Bergmann <sbergman@redhat.com>2012-11-29 11:36:58 +0100
commit79e5ee5f6949f4b8645ef32dba61705d02473c60 (patch)
tree2042e4b002d19e7d828b838537278ca9f10da629 /configure.ac
parent053108588dd634838457ba81e7dc70e82aa50e02 (diff)
Isolate PDF Import so it can be made optionally installable
...which can be attractive for installation sets that use --with-system-poppler but do not want the LO core package to depend on a poppler package. See the comment at the top of scp2/source/ooo/module_pdfimport.scp for details. The build-time --disable-pdfimport configure switch is gone, PDF Import is built unconditionally for all platforms but Android and iOS now. (The ENABLE_PDFIMPORT variable now uses TRUE/FALSE rather than YES/NO, to increase consistency across those variables.) Change-Id: I6509d0b2e770b276cd54540408fb1ec5a7dda058
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index ef57fbb52e67..c40e5232b387 100644
--- a/configure.ac
+++ b/configure.ac
@@ -565,11 +565,6 @@ AC_ARG_ENABLE(extensions,
[Disable all add-on extension functionality. Work in progress, use only if you are hacking on it.])
)
-AC_ARG_ENABLE(pdfimport,
- AS_HELP_STRING([--disable-pdfimport],
- [Disable PDF import.])
-)
-
AC_ARG_ENABLE(scripting,
AS_HELP_STRING([--disable-scripting],
[Disable BASIC, Java and Python. Work in progress, use only if you are hacking on it.])
@@ -4157,11 +4152,11 @@ if test "$cross_compiling" = "yes"; then
./configure \
--disable-graphite \
--disable-build-mozilla \
- --disable-pdfimport \
--disable-postgresql-sdbc \
--disable-zenity \
--with-parallelism="$with_parallelism" \
--without-doxygen \
+ ENABLE_PDFIMPORT=FALSE \
$sub_conf_opts \
2>&1 | sed -e 's/^/ /'
test -f ./config_host.mk 2>/dev/null || exit
@@ -9795,9 +9790,9 @@ AC_SUBST(ENABLE_MINIMIZER)
# pdf import?
AC_MSG_CHECKING([whether to build the PDF import])
-if test "x$enable_pdfimport" != "xno"; then
+if test "$_os" != Android -a "$_os" != iOS -a "$ENABLE_PDFIMPORT" != FALSE; then
AC_MSG_RESULT([yes])
- ENABLE_PDFIMPORT=YES
+ ENABLE_PDFIMPORT=TRUE
dnl ===================================================================
dnl Check for system poppler
@@ -9825,8 +9820,7 @@ if test "x$enable_pdfimport" != "xno"; then
fi
else
AC_MSG_RESULT([no])
- ENABLE_PDFIMPORT=NO
- SCPDEFS="$SCPDEFS -DWITHOUT_PDFIMPORT"
+ ENABLE_PDFIMPORT=FALSE
fi
AC_SUBST(ENABLE_PDFIMPORT)
AC_SUBST(SYSTEM_POPPLER)