summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2013-02-05 15:18:43 +0100
committerMichael Stahl <mstahl@redhat.com>2013-02-05 15:13:16 +0000
commit3251bb47527ebbc657902ad229ac1e076bf28c2a (patch)
tree00b7e6bd7b7002f02fb5ed8a066f0f203f48afbb /configure.ac
parent1ceb97fdd46b2eb6ebf5aded10cb2a8f33cd5a7a (diff)
use "icerun" wrapper only when available
It is not provided by the old icecram-0.9.2 on SLED11 Change-Id: If8dc9b028276ac05733eb59c1ec62e352f4a2796 Reviewed-on: https://gerrit.libreoffice.org/2000 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0cbc7e850b0c..5bdbd371dad2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12025,9 +12025,13 @@ dnl icerun is a wrapper that stops us spawning tens of processes
dnl locally - for tools that can't be executed on the compile cluster
dnl this avoids a dozen javac's ganging up on your laptop to kill it.
dnl ===================================================================
+AC_MSG_CHECKING([whether to use icerun wrapper])
ICECREAM_RUN=
-if test "$enable_icecream" = "yes"; then
- ICECREAM_RUN=icerun
+if test "$enable_icecream" = "yes" && which icerun >/dev/null 2>&1 ; then
+ ICECREAM_RUN=icerun
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
fi
AC_SUBST(ICECREAM_RUN)