summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-12-04 11:26:39 +0200
committerMichael Meeks <michael.meeks@suse.com>2013-02-13 13:57:09 +0000
commit185e1be6cd1954b8cc5a302c879384f2549cd060 (patch)
treea4fc37852d43af45f045a1ca0a3bcfdce5c10fb0 /configure.ac
parenta648103cfc0c4d51f2ad929d9514561e47106a9e (diff)
Let's try to enable compiling the Bluetooth code for Windows
(cherry picked from commit 17f7ee8442472e3ef743891b4d4f1a6a8c063472) Change-Id: Ic761c6c7dd17b42098adc44f7f4435b83ed3d009 Reviewed-on: https://gerrit.libreoffice.org/2129 Reviewed-by: Michael Meeks <michael.meeks@suse.com> Tested-by: Michael Meeks <michael.meeks@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 24 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index e7c06f2536f9..bb3f96ceed88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -862,9 +862,8 @@ AC_ARG_ENABLE(sdremote,
AC_ARG_ENABLE(sdremote-bluetooth,
AS_HELP_STRING([--disable-sdremote-bluetooth],
- [Determines whether to build sdremote with bluetooth support
- Requires: dbus]),
-,enable_sdremote_bluetooth=yes)
+ [Determines whether to build sdremote with bluetooth support.
+ Requires dbus on Linux.]))
AC_ARG_ENABLE(gconf,
AS_HELP_STRING([--disable-gconf],
@@ -9298,12 +9297,28 @@ else
fi
AC_SUBST(ENABLE_PACKAGEKIT)
-AC_MSG_CHECKING([whether to enable sd remotecontrol])
+AC_MSG_CHECKING([whether to enable Impress remote control])
if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
AC_MSG_RESULT([yes])
ENABLE_SDREMOTE=YES
- AC_MSG_CHECKING([whether to enable bluetooth support in sdremote])
- if test -n "$enable_sdremote_bluetooth" -a "$enable_sdremote_bluetooth" != "no"; then
+ AC_MSG_CHECKING([whether to enable Bluetooth support in Impress remote control])
+
+ # If not explicitly enabled or disabled, default
+ if test -z "$enable_sdremote_bluetooth"; then
+ case "$OS" in
+ LINUX|WNT)
+ # Default to yes for these
+ enable_sdremote_bluetooth=yes
+ ;;
+ *)
+ # otherwise no
+ enable_sdremote_bluetooth=no
+ ;;
+ esac
+ fi
+ # $enable_sdremote_bluetooth is guaranteed non-empty now
+
+ if test "$enable_sdremote_bluetooth" != "no"; then
if test "$OS" = "LINUX"; then
if test "$ENABLE_DBUS" = "TRUE"; then
AC_MSG_RESULT([yes])
@@ -9311,7 +9326,7 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
dnl ===================================================================
dnl Check for system bluez
dnl ===================================================================
- AC_MSG_CHECKING([which bluetooth header to use])
+ AC_MSG_CHECKING([which Bluetooth header to use])
if test "$with_system_bluez" = "yes"; then
AC_MSG_RESULT([external])
AC_CHECK_HEADER(bluetooth/bluetooth.h, [],
@@ -9325,9 +9340,8 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
ENABLE_SDREMOTE_BLUETOOTH=NO
fi
else
- # FIXME: should this really be disabled in everything non-Linux?
- AC_MSG_RESULT([no])
- ENABLE_SDREMOTE_BLUETOOTH=NO
+ AC_MSG_RESULT([yes])
+ ENABLE_SDREMOTE_BLUETOOTH=YES
fi
else
AC_MSG_RESULT([no])