summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2012-11-08 09:41:32 +0100
committerJan Holesovsky <kendy@suse.cz>2012-11-08 10:18:00 +0100
commitf102d993270fbb7b429cec5c34cfd73acfe213b1 (patch)
tree0cc8441db2014174f5aedf0efe29b7b8127948d0 /configure.ac
parent28f2c6b826f1693dc5136d552e5446d3d52aa329 (diff)
MinGW: Fix visibility checks.
Change-Id: I7f2718a60d55f5d99275646875a64e53c805b210
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b018638b3353..09d4722decd1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -342,6 +342,10 @@ cygwin*|interix*|mingw32*)
_os=WINNT
use_shl_version="TRUE"
DYNAMIC_CRT="TRUE"
+
+ DLLPOST=".dll"
+ LINKFLAGSNOUNDEFS=
+
# If the host OS matches "mingw32*", that means we are using the
# MinGW cross-compiler, because we don't see the point in building
# LibreOffice using MinGW on Windows. If you want to build on
@@ -5572,7 +5576,7 @@ _ACEOF
else
case "$host_cpu" in
i?86|x86_64)
- if test "$_os" = "Darwin"; then
+ if test "$_os" = "Darwin" -o "$WITH_MINGW" = "yes"; then
gccvisbroken=no
else
if $EGREP -q '@PLT|@GOT' visibility.s; then