summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-11-03 10:30:08 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-11-03 10:30:08 +0200
commitcb225ab3a25bef4ac304ec314b61e75369440e38 (patch)
treece0c361740e872f6dc1af5c5985288399c33b3f9 /configure.ac
parentbef4daee6631f92e737df31af6d3a8779dfa9720 (diff)
Don't look for a x64 compiler separately if we are building with it
This change just to avoid misleading warnings. Will have to verify later that a proper 64-bit Explorer extension gets built in this case. (There should be no need to build a separate 32-bit Explorer extension when building a 64-bit LibreOffice. After all, a 64-bit LO can be installed only on a 64-bit OS with a 64-bit Explorer.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 22 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index f6a7fec20f12..e9c035bee153 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3201,27 +3201,29 @@ if test "$_os" = "WINNT"; then
LINK_X64_BINARY=
LIBMGR_X64_BINARY=
- AC_MSG_CHECKING([for a x64 compiler and libraries for 64-bit Explorer extensions])
- if test "$BITNESS_OVERRIDE" = "" -a -f "$with_cl_home/atlmfc/lib/amd64/atls.lib"; then
- # Prefer native x64 compiler to cross-compiler, in case we are running
- # the build on a 64-bit OS.
- if "$with_cl_home/bin/amd64/cl.exe" -? </dev/null >/dev/null 2>&1; then
- BUILD_X64=TRUE
- CXX_X64_BINARY="$with_cl_home/bin/amd64/cl.exe"
- LINK_X64_BINARY="$with_cl_home/bin/amd64/link.exe"
- LIBMGR_X64_BINARY="$with_cl_home/bin/amd64/lib.exe"
- elif "$with_cl_home/bin/x86_amd64/cl.exe" -? </dev/null >/dev/null 2>&1; then
- BUILD_X64=TRUE
- CXX_X64_BINARY="$with_cl_home/bin/x86_amd64/cl.exe"
- LINK_X64_BINARY="$with_cl_home/bin/x86_amd64/link.exe"
- LIBMGR_X64_BINARY="$with_cl_home/bin/x86_amd64/lib.exe"
+ if test "$BITNESS_OVERRIDE" = ""; then
+ AC_MSG_CHECKING([for a x64 compiler and libraries for 64-bit Explorer extensions])
+ if test -f "$with_cl_home/atlmfc/lib/amd64/atls.lib"; then
+ # Prefer native x64 compiler to cross-compiler, in case we are running
+ # the build on a 64-bit OS.
+ if "$with_cl_home/bin/amd64/cl.exe" -? </dev/null >/dev/null 2>&1; then
+ BUILD_X64=TRUE
+ CXX_X64_BINARY="$with_cl_home/bin/amd64/cl.exe"
+ LINK_X64_BINARY="$with_cl_home/bin/amd64/link.exe"
+ LIBMGR_X64_BINARY="$with_cl_home/bin/amd64/lib.exe"
+ elif "$with_cl_home/bin/x86_amd64/cl.exe" -? </dev/null >/dev/null 2>&1; then
+ BUILD_X64=TRUE
+ CXX_X64_BINARY="$with_cl_home/bin/x86_amd64/cl.exe"
+ LINK_X64_BINARY="$with_cl_home/bin/x86_amd64/link.exe"
+ LIBMGR_X64_BINARY="$with_cl_home/bin/x86_amd64/lib.exe"
+ fi
+ fi
+ if test "$BUILD_X64" = TRUE; then
+ AC_MSG_RESULT([found])
+ else
+ AC_MSG_RESULT([not found])
+ AC_MSG_WARN([Installation set will not contain 64-bit Explorer extensions])
fi
- fi
- if test "$BUILD_X64" = TRUE; then
- AC_MSG_RESULT([found])
- else
- AC_MSG_RESULT([not found])
- AC_MSG_WARN([Installation set will not contain 64-bit Explorer extensions])
fi
AC_SUBST(BUILD_X64)