summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-09-22 00:07:53 +0300
committerAndras Timar <andras.timar@collabora.com>2015-05-19 12:52:11 +0200
commit49d048a2c8a8159e0e478d405f4c29d652362d75 (patch)
tree65b9cb65353b2a52223ac2e17e0457f1d042b3f9 /configure.ac
parent8ebb31f73a68a388a2c37d810db92c6fce35b0b2 (diff)
The com.apple.application-identifier value should be prefixed with the teamid
Change-Id: I6b58492ba051bb5032870aa47cfacbe3a292e31f Conflicts: configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4cdb969f2860..65c9124a542e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1344,6 +1344,12 @@ AC_ARG_ENABLE(macosx-sandbox,
adherence to App Store rules.]),
,)
+AC_ARG_WITH(macosx-teamid,
+ AS_HELP_STRING([--with-macosx-teamid=<teamid>],
+ [The "team id" to be used for com.apple.application-identifier
+ in the entitlements when building a sandboxed LibreOffice.]),
+,)
+
AC_ARG_WITH(macosx-bundle-identifier,
AS_HELP_STRING([--with-macosx-bundle-identifier=tld.mumble.orifice.TheOffice],
[Define the OS X bundle identifier. Default is the somewhat weird
@@ -2892,8 +2898,14 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([whether to sandbox the application])
+ if test -n "$with_macosx_teamid" -a "$with_macosx_teamid != yes -a "$with_macosx_teamid != no; then
+ MACOSX_TEAMID="$with_macosx_teamid"
+ fi
+
if test -z "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([OS X sandboxing requires code signing])
+ elif test -z "$MACOSX_TEAMID" -a "$enable_macosx_sandbox" = yes; then
+ AC_MSG_ERROR([OS X sandboxing requires a team id])
elif test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([OS X sandboxing (actually App Store rules) disallows use of Java])
elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
@@ -2924,6 +2936,7 @@ AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(MACOSX_PACKAGE_SIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_SUBST(MACOSX_TEAMID)
AC_SUBST(MACOSX_APP_NAME)
AC_SUBST(MACOSX_HIGH_RESOLUTION_VALUE)