summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Ostrovsky <david@ostrovsky.org>2016-02-20 10:30:21 +0100
committerNorbert Thiebaud <nthiebaud@gmail.com>2016-02-21 19:38:53 +0000
commit3ff41a00aa25922be4cb71a657b124a1c4a8aef7 (patch)
tree330ca5ef158e0cdf80a2e6433efe26c1e6918cab /configure.ac
parenta2d8a9873deb5b39198c346cf637a9a8cb9e5105 (diff)
Fix UCRT detection
Change-Id: If2ef7a8b507e9d65f1f1ee186491ce2f35340362 Reviewed-on: https://gerrit.libreoffice.org/22545 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0a200e68c540..f1d8e94fc934 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3481,13 +3481,14 @@ if test "$_os" = "WINNT"; then
if test -n "$ucrttest"; then
AC_MSG_RESULT([found])
PathFormat "$ucrttest"
- ucrtincpath_formatted="$formatted_path/Include/$ucrtdir/ucrt"
+ ucrtincpath_formatted="${formatted_path}Include/$ucrtdir/ucrt"
# SOLARINC is used for external modules and must be set too.
# And no, it's not sufficient to set SOLARINC only, as configure
# itself doesn't honour it.
SOLARINC="$SOLARINC -I$ucrtincpath_formatted"
CFLAGS="$CFLAGS -I$ucrtincpath_formatted"
- CXXFLAGS="$CPPFLAGS -I$ucrtincpath_formatted"
+ CXXFLAGS="$CXXFLAGS -I$ucrtincpath_formatted"
+ CPPFLAGS="$CPPFLAGS -I$ucrtincpath_formatted"
else
AC_MSG_ERROR([not found])
fi
@@ -12478,7 +12479,7 @@ if test "$build_os" = "cygwin"; then
fi
if test $VCVER = 140; then
PathFormat "$ucrttest"
- ucrtlibpath_formatted="$formatted_path/lib/$ucrtdir/ucrt/x64"
+ ucrtlibpath_formatted="${formatted_path}lib/$ucrtdir/ucrt/x64"
ILIB="$ILIB;$ucrtlibpath_formatted"
fi
else
@@ -12492,7 +12493,7 @@ if test "$build_os" = "cygwin"; then
fi
if test $VCVER = 140; then
PathFormat "$ucrttest"
- ucrtlibpath_formatted="$formatted_path/lib/$ucrtdir/ucrt/x86"
+ ucrtlibpath_formatted="${formatted_path}lib/$ucrtdir/ucrt/x86"
ILIB="$ILIB;$ucrtlibpath_formatted"
fi
fi