summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-11-08 10:53:14 +0200
committerTor Lillqvist <tml@iki.fi>2012-11-08 10:57:39 +0200
commit386d7762aee953f052c945bd1039bb01ead66182 (patch)
tree3bea42940b2af1b8376a3929346b0c9d4378195a /configure.ac
parent3be8c2274f6c7e19ce252711be13639bec2c74b8 (diff)
Avoid pointless warning when building experimental code anyway
Change-Id: Ied9a4fb4eed0a7fda8e6b1bd03a3dbc476797587
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index e2e9d670951a..38a3f288c474 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2732,22 +2732,24 @@ if test "$_os" = "Darwin"; then
esac
fi
- case "$with_macosx_version_min_required" in
- 10.4)
- case "$with_macosx_sdk" in
+ if test "$BITNESS_OVERRIDE" == ""; then
+ case "$with_macosx_version_min_required" in
10.4)
+ case "$with_macosx_sdk" in
+ 10.4)
+ ;;
+ *)
+ AC_MSG_WARN([Building with a SDK > 10.4 possibly breaks 10.4 compatibility. Do not use for deliverable build until verified that it really works])
+ add_warning "Building with a SDK > 10.4 possibly breaks 10.4 compatibility. Do not use for deliverable build until verified that it really works"
+ ;;
+ esac
;;
*)
- AC_MSG_WARN([Building with a SDK > 10.4 possibly breaks 10.4 compatibility. Do not use for deliverable build until verified that it really works])
- add_warning "Building with a SDK > 10.4 possibly breaks 10.4 compatibility. Do not use for deliverable build until verified that it really works"
+ AC_MSG_WARN([Building with a minimum version requirement > 10.4 breaks 10.4 compatibility. Do not use for deliverable build])
+ add_warning "Building with a minimum version requirement > 10.4 breaks 10.4 compatibility. Do not use for deliverable build"
;;
esac
- ;;
- *)
- AC_MSG_WARN([Building with a minimum version requirement > 10.4 breaks 10.4 compatibility. Do not use for deliverable build])
- add_warning "Building with a minimum version requirement > 10.4 breaks 10.4 compatibility. Do not use for deliverable build"
- ;;
- esac
+ fi
# If no CC and CXX environment vars, try to guess where the compiler is
if test -z "$save_CC"; then