summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-02-25 20:27:59 +0100
committerStephan Bergmann <sbergman@redhat.com>2016-02-26 08:57:07 +0100
commit128deeae81a6f802bfb79b8f0fa8c4b10729f7db (patch)
treedbf0f693609d17fee8c011c9e684e746cf53b408 /configure.ac
parentbaad027bb7d4e4cd3c80ec3051741d21a8d23511 (diff)
cxxabi.h is not specific to GCC
Change-Id: Icaf4d4d41a36ae469f826ac08ab641a554dff3c9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 78253497f883..1043c9fd60ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6047,7 +6047,7 @@ if test "$GCC" = "yes"; then
#include <cxxabi.h>
void * f() { return __cxxabiv1::__cxa_allocate_exception(0); }
])], [
- AC_DEFINE([HAVE_GCC_CXXABI_H_CXA_ALLOCATE_EXCEPTION],[1])
+ AC_DEFINE([HAVE_CXXABI_H_CXA_ALLOCATE_EXCEPTION],[1])
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
@@ -6058,7 +6058,7 @@ if test "$GCC" = "yes"; then
#include <cxxabi.h>
void * f() { return __cxxabiv1::__cxa_get_globals(); }
])], [
- AC_DEFINE([HAVE_GCC_CXXABI_H_CXA_GET_GLOBALS],[1])
+ AC_DEFINE([HAVE_CXXABI_H_CXA_GET_GLOBALS],[1])
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
@@ -6069,7 +6069,7 @@ if test "$GCC" = "yes"; then
#include <cxxabi.h>
void f() { __cxxabiv1::__cxa_throw(0, 0, 0); }
])], [
- AC_DEFINE([HAVE_GCC_CXXABI_H_CXA_THROW],[1])
+ AC_DEFINE([HAVE_CXXABI_H_CXA_THROW],[1])
AC_MSG_RESULT([yes])
], [AC_MSG_RESULT([no])])
AC_LANG_POP([C++])
@@ -12855,10 +12855,10 @@ AC_CONFIG_HEADERS([config_host/config_eot.h])
AC_CONFIG_HEADERS([config_host/config_extension_update.h])
AC_CONFIG_HEADERS([config_host/config_cairo_canvas.h])
AC_CONFIG_HEADERS([config_host/config_cups.h])
+AC_CONFIG_HEADERS([config_host/config_cxxabi.h])
AC_CONFIG_HEADERS([config_host/config_dbus.h])
AC_CONFIG_HEADERS([config_host/config_features.h])
AC_CONFIG_HEADERS([config_host/config_folders.h])
-AC_CONFIG_HEADERS([config_host/config_gcc.h])
AC_CONFIG_HEADERS([config_host/config_gio.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])