summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Mencken <dougmencken@gmail.com>2013-12-12 08:08:22 -0500
committerNorbert Thiebaud <nthiebaud@gmail.com>2013-12-17 12:15:44 +0000
commit877f7e6eaee9d7da176d02b06dee9847cc332d13 (patch)
tree5038ad6549de3d3530b6b4873dd09d662b1e4f8f /configure.ac
parent9cd1ab37e9541a4a781b52eb41c8db8c9c3bda29 (diff)
Add check for touch -h to configure.ac
Change-Id: I53c452dac9cef64fce9a3e7e28956efe95fc4c24 Reviewed-on: https://gerrit.libreoffice.org/7046 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7c8c807c745..687965c443c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9948,6 +9948,15 @@ if test $build_os = cygwin; then
fi
dnl ===================================================================
+dnl We need touch with -h option support.
+dnl ===================================================================
+AC_PATH_PROG(TOUCH, touch)
+test -z "$TOUCH" && AC_MSG_ERROR([touch is required])
+if ! "$TOUCH" -h /dev/null 2>/dev/null > /dev/null; then
+ AC_MSG_ERROR([touch version with -h option support is required to build, please install it and make sure it is the one found first in PATH],,)
+fi
+
+dnl ===================================================================
dnl Test which vclplugs have to be built.
dnl ===================================================================
R=""