summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGabor Kelemen <kelemeng@ubuntu.com>2022-04-28 11:14:24 +0200
committerThorsten Behrens <thorsten.behrens@allotropia.de>2022-05-04 16:48:25 +0200
commit079659eb7d15f15a37f1f508beb5cffe24fe6f25 (patch)
treee03670f501dbb9e52ba78a2ff226a2d4fbdee4bd /configure.ac
parent405ab5c3307948bfcf12670d7ac6df0b86fb8832 (diff)
Drop --with-iwyu option
Nowadays the bin/find-unneeded-includes script is a better solution for this problem This essentially reverts the commits: c716b3888e7e8150d1c1053ee6550afb56438b1f 096c7e889f3b9bd42a81fb0216e2a68fb27159fc 40e7eecb7efeeb9af59206d7a9c82ac55adf5279 Change-Id: I404a4b34176efaacf961605559af9de6d6cba10a Reviewed-on: https://gerrit.libreoffice.org/c/core/+/133540 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de> Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 776dbe918d94..ec9175d1964a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2654,12 +2654,6 @@ libo_FUZZ_ARG_WITH(gssapi,
where a good system GSSAPI is available.]),
,)
-AC_ARG_WITH(iwyu,
- AS_HELP_STRING([--with-iwyu],
- [Use given IWYU binary path to check unneeded includes instead of building.
- Use only if you are hacking on it.]),
-,)
-
libo_FUZZ_ARG_WITH(lxml,
AS_HELP_STRING([--without-lxml],
[gla11y will use python lxml when available, potentially building a local copy if necessary.
@@ -14286,14 +14280,6 @@ else
fi
AC_SUBST(PARALLELISM)
-IWYU_PATH="$with_iwyu"
-AC_SUBST(IWYU_PATH)
-if test ! -z "$IWYU_PATH"; then
- if test ! -f "$IWYU_PATH"; then
- AC_MSG_ERROR([cannot find include-what-you-use binary specified by --with-iwyu])
- fi
-fi
-
#
# Set up ILIB for MSVC build
#