summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-06-06 10:49:22 +0300
committerTor Lillqvist <tml@collabora.com>2014-06-08 10:43:17 +0300
commitd7b3b5c09d2acbdf385cbf3b87002235594e14ad (patch)
tree512448da44e5c7c9af189522d4cc00f1d65de87b /configure.ac
parentf3dc0e2aba005ce06991e8c7c50f0c8eebea3559 (diff)
Add --with-macosx-app-name configure option that propagates to MACOSX_APP_NAME
Change-Id: I5997669d9e990c302871e08a336a4d8365d5aa13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 799558830c5e..9cc15839c5b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1306,6 +1306,11 @@ AC_ARG_WITH(macosx-bundle-identifier,
org.libreoffice.script ("script", huh?).]),
,with_macosx_bundle_identifier=org.libreoffice.script)
+AC_ARG_WITH(macosx-app-name,
+ AS_HELP_STRING([--with-macosx-app-name='My Own Office Suite'],
+ [Define the OS X app name. Default is AC_PACKAGE_NAME.]),
+,with_macosx_app_name=$PRODUCTNAME)
+
AC_ARG_ENABLE(ios-simulator,
AS_HELP_STRING([--enable-ios-simulator],
[Build for the iOS Simulator, not iOS device.]),
@@ -2994,11 +2999,13 @@ if test $_os = Darwin; then
fi
AC_MSG_CHECKING([what OS X app bundle identifier to use])
-
MACOSX_BUNDLE_IDENTIFIER=$with_macosx_bundle_identifier
-
AC_MSG_RESULT([$MACOSX_BUNDLE_IDENTIFIER])
+ AC_MSG_CHECKING([what OS X app name to use])
+ MACOSX_APP_NAME="$with_macosx_app_name"
+ AC_MSG_RESULT([$MACOSX_APP_NAME])
+
AC_MSG_CHECKING([build with mac retina support])
if test "$enable_macosx_retina" = yes ; then
MACOSX_HIGH_RESOLUTION_VALUE=true
@@ -3017,6 +3024,7 @@ AC_SUBST(LIBTOOL) # Note that the OS X libtool command is unrelated to GNU libto
AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_SUBST(MACOSX_APP_NAME)
AC_SUBST(MACOSX_HIGH_RESOLUTION_VALUE)
dnl ===================================================================