summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDouglas Mencken <dougmencken@gmail.com>2014-07-08 13:22:03 -0400
committerMichael Stahl <mstahl@redhat.com>2014-07-08 18:45:58 +0000
commit08abec41d682e67670f1f60aa71e6fd8bf81a927 (patch)
tree35b327dbf6899df6733424cfca91339bf2e5f573 /configure.ac
parent6f092beb46796b8a6cc94b5f4cbe509bf541fae2 (diff)
Bump build-time system python's requirement to 2.6.
"Writing Python code that is OK on 2.x and 3.x is next to impossible when 2.x is 2.5" --Miklos Vajna Change-Id: I432c2773eb60ab3bd5cc907407ca5159ce4390ad Reviewed-on: https://gerrit.libreoffice.org/10116 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index efe0bf4aebbb..e5153eaa05c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1059,7 +1059,7 @@ AC_ARG_ENABLE(python,
[Enables or disables Python support at run-time and build-time.
Also specifies what Python to use. 'auto' is the default.
'fully-internal' even forces the internal version for uses of Python
- during the build (for testing purposes, mainly).]))
+ during the build.]))
AC_ARG_ENABLE(gtk,
AS_HELP_STRING([--disable-gtk],
@@ -8023,14 +8023,14 @@ AC_SUBST(LIBXML_LIBS)
AC_SUBST(XMLLINT)
# =====================================================================
-# Checking for a Python interpreter with version >= 2.5 needed to build LO.
-# runtime requires Python 3 compatible version (>= 2.6)
+# Checking for a Python interpreter with version >= 2.6.
+# Build and runtime requires Python 3 compatible version (>= 2.6).
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
if test "$build_os" != "cygwin" -a "$enable_python" != fully-internal; then
# This allows a lack of system python with no error, we use internal one in that case.
- AM_PATH_PYTHON([2.5],, [:])
+ AM_PATH_PYTHON([2.6],, [:])
# Clean PYTHON_VERSION checked below if cross-compiling
PYTHON_VERSION=""
if test "$PYTHON" != ":"; then
@@ -8073,8 +8073,12 @@ no|disable)
# we actually do check anew.
unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
AM_PATH_PYTHON([3.3],, [:])
- if test "$PYTHON" = :; then
- AC_MSG_RESULT([internal])
+ if test "$PYTHON" = ":"; then
+ if test -z "$PYTHON_FOR_BUILD"; then
+ AC_MSG_RESULT([fully internal])
+ else
+ AC_MSG_RESULT([internal])
+ fi
enable_python=internal
else
AC_MSG_RESULT([system])
@@ -8103,9 +8107,6 @@ fi
if test $enable_python = system; then
if test -z "$PYTHON_CFLAGS" -a $_os = Darwin; then
- # We already have logic above to make sure the system Python
- # is used only when building against SDK 10.6 or newer.
-
# Make sure we use the 2.6 Python when building against the
# 10.6 SDK.
case $with_macosx_sdk in
@@ -8114,7 +8115,7 @@ if test $enable_python = system; then
10.7|10.8)
python_version=2.7;;
*)
- # ???
+ # 10.9 etc.
python_version=2.7;;
esac
PYTHON=python$python_version