summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@gmail.com>2015-04-20 19:48:38 +0200
committerMatúš Kukan <matus.kukan@gmail.com>2015-04-22 19:00:32 +0200
commitfa8aaaadc38372185d6d29d8d91391907e95b689 (patch)
tree347b6a293d8bd0525b94a22bdac00ab0c0edfb67 /configure.ac
parent0cf38e7d0c5d2b67dca828aae1797bff58b6c5fe (diff)
Bin confusing --enable-mergelibs=all option
It was most probably not working anyway and is something different to libmerged, which intends to merge only core set of libraries. To build everything into one library, approach similar to what we do for Android could be better idea. Change-Id: Id5b8c2fa2b26e8faaaeb022ea55eb2e39909e875
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 3 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 0d492ad38dd2..d2a7aba97ed8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -915,11 +915,10 @@ AC_ARG_ENABLE([hardlink-deliver],
)
AC_ARG_ENABLE(mergelibs,
- AS_HELP_STRING([--enable-mergelibs=<all/yes>],
+ AS_HELP_STRING([--enable-mergelibs],
[Enables linking of big, merged, library. Experimental feature, tested
only for Linux at some stage in history, but possibly does not work even
- for Linux any more. 'all' will link a lot of libraries into libmerged
- while 'yes' will do it for just a core set of libraries.])
+ for Linux any more. This will link a core set of libraries into libmerged.])
)
AC_ARG_ENABLE(graphite,
@@ -12735,12 +12734,7 @@ if test -n "$enable_mergelibs" -a "$enable_mergelibs" != "no"; then
if test $_os != Linux -a $_os != WINNT; then
add_warning "--enable-mergelibs is not tested for this platform"
fi
- if test "$enable_mergelibs" = "all"; then
- MERGELIBS="ALL"
- AC_DEFINE(STATIC_LINKING)
- else
- MERGELIBS="CORE"
- fi
+ MERGELIBS="TRUE"
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])