summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-13 12:47:07 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2015-10-13 12:50:37 +0200
commit2ca4748a2e04b37c18f6f572bcf323cd857fef34 (patch)
tree6d12be1bf4de17fa8abe6dce2025817662b0d66a /configure.ac
parent9af1331c9253426855ac0f3a26e7f4bfff900d61 (diff)
add warning with install instructions when android build-tools are not found
Change-Id: I987262e4e9ae99c889285658fc9f840655d29191
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5b8b3a8aa4b9..812450d2e403 100644
--- a/configure.ac
+++ b/configure.ac
@@ -848,6 +848,16 @@ if echo "$host_os" | grep -q linux-android ; then
if test ! -d "$ANDROID_SDK_HOME/platforms"; then
AC_MSG_ERROR([the --with-android-sdk option does not point to an Android SDK])
fi
+
+ BUILD_TOOLS_VERSION=`$SED -n -e 's/.*buildToolsVersion "\(.*\)"/\1/p' $SRC_ROOT/android/source/build.gradle`
+ if test ! -d "$ANDROID_SDK_HOME/build-tools/$BUILD_TOOLS_VERSION"; then
+ AC_MSG_WARN([android build-tools $BUILD_TOOLS_VERSION not found - install with
+ $ANDROID_SDK_HOME/tools/android update sdk -u --all --filter build-tools-$BUILD_TOOLS_VERSION
+ or adjust change $SRC_ROOT/android/source/build.gradle accordingly])
+ add_warning "android build-tools $BUILD_TOOLS_VERSION not found - install with"
+ add_warning " $ANDROID_SDK_HOME/tools/android update sdk -u --all --filter build-tools-$BUILD_TOOLS_VERSION"
+ add_warning "or adjust $SRC_ROOT/android/source/build.gradle accordingly"
+ fi
fi
if test "$_os" = "AIX"; then