summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2015-10-12 22:13:37 +0200
committerCaolán McNamara <caolanm@redhat.com>2015-10-14 08:09:40 +0000
commit068c04fb06806a9345c0059545d19a416d7e60b7 (patch)
tree0a0790e03929f9e862baf9347dbe76fc10661c1e /configure.ac
parenta69a786b91048d69bbb47503e3720de613935e56 (diff)
Bump gtk+ version to 2.18
2.18 is the version available in RHEL 6 released in 2010. Change-Id: I4cd4fc89f6b51e6f58ca72b8182f80316b1f4f88 Reviewed-on: https://gerrit.libreoffice.org/19330 Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bea248406784..e1814edef494 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10125,7 +10125,7 @@ ENABLE_SYSTRAY_GTK=""
if test "$test_gtk" = "yes"; then
if test "$ENABLE_GTK" = "TRUE"; then
- PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.10.0 gdk-pixbuf-2.0 >= 2.2 ,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.18.0 gdk-pixbuf-2.0 >= 2.2 ,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
GTK_CFLAGS=$(printf '%s' "$GTK_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
PKG_CHECK_MODULES(GTHREAD, gthread-2.0,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
BUILD_TYPE="$BUILD_TYPE GTK"
@@ -10181,7 +10181,7 @@ if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_telepathy" = "yes";
ENABLE_TELEPATHY="TRUE"
AC_DEFINE(ENABLE_TELEPATHY)
AC_MSG_RESULT([yes])
- PKG_CHECK_MODULES( TELEPATHY, telepathy-glib >= 0.18.0 glib-2.0 gobject-2.0 gthread-2.0 gio-2.0 gtk+-2.0 >= 2.10 )
+ PKG_CHECK_MODULES( TELEPATHY, telepathy-glib >= 0.18.0 glib-2.0 gobject-2.0 gthread-2.0 gio-2.0 gtk+-2.0 >= 2.18.0 )
TELEPATHY_CFLAGS=$(printf '%s' "$TELEPATHY_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
else
AC_MSG_RESULT([no])